k8s crd inferenceservices.serving.kserve.io

背景

ArgoCD无法连接到k8s集群
日志如下:

yaml 复制代码
Failed to load live state: failed to get cluster info for "https://kubernetes.default.svc": error synchronizing cache state : failed to sync cluster https://10.233.0.1:443: failed to load initial state of resource InferenceService.serving.kserve.io: Internal error occurred: error resolving resource

解决过程

crd详细信息

yaml 复制代码
Status:
  Accepted Names:
    Kind:       InferenceService
    List Kind:  InferenceServiceList
    Plural:     inferenceservices
    Short Names:
      isvc
    Singular:  inferenceservice
  Conditions:
    Last Transition Time:  2024-04-28T13:39:36Z
    Message:               no conflicts found
    Reason:                NoConflicts
    Status:                True
    Type:                  NamesAccepted
    Last Transition Time:  2024-04-28T13:39:36Z
    Message:               the initial names have been accepted
    Reason:                InitialNamesAccepted
    Status:                True
    Type:                  Established
    Last Transition Time:  2024-04-28T13:47:01Z
    Message:               could not list instances: unable to find a custom resource client for inferenceservices.serving.kserve.io: unable to load root certificates: unable to parse bytes as PEM block
    Reason:                InstanceDeletionFailed
    Status:                True
    Type:                  Terminating
  Stored Versions:
    v1beta1
Events:  <none>

删除此crd资源

bash 复制代码
kubectl delete customresourcedefinitions.apiextensions.k8s.io inferenceservices.serving.kserve.io --force
warning: Immediate deletion does not wait for confirmation that the running resource has been terminated. The resource may continue to run on the cluster indefinitely.
customresourcedefinition.apiextensions.k8s.io "inferenceservices.serving.kserve.io" force deleted

^C
发现无法正常删除,可通过patch进行清理

kubectl patch crd inferenceservices.serving.kserve.io -p '{"metadata":{"finalizers":[]}}' --type=merge
customresourcedefinition.apiextensions.k8s.io/inferenceservices.serving.kserve.io patched
相关推荐
sbjdhjd13 小时前
云安全 | Docker 容器逃逸复盘(二):2375 未授权接口如何突破容器管理边界
网络安全·docker·云原生·数据挖掘·开源·云计算·云安全
吴声子夜歌15 小时前
Docker入门与实战——初识Docker与容器
docker·容器
MrSYJ17 小时前
Docker端口映射咋做的,模拟下。
docker·云原生·kubernetes
张小凡vip17 小时前
Kubernetes--k8s---了解和使用configmap挂载配置文件
云原生·容器·kubernetes
bluebonnet2718 小时前
【docker】容器内映射外部音频驱动
docker·容器·音视频
吴声子夜歌19 小时前
Docker入门与实战——核心概念与安装配置
运维·docker·容器
guo_wen_qiang1 天前
docker的备份与迁移
运维·docker·容器
寻林写彡1 天前
云安全 | Docker 容器逃逸复盘(一):从隔离边界到运行时链路,如何确认自己身处容器
安全·云原生
小小龙学IT1 天前
Kubernetes 深度实践:架构、API 与避坑指南
容器·架构·kubernetes
MrSYJ2 天前
别人再问你路由表是啥,这篇文章摔它脸上
docker·云原生·kubernetes