nginx 负载均衡配置详解

基于 ${nginx_home}/conf/nginx.conf 文件配置实现,如下:

c 复制代码
http {
	   	# 定义server地址
	    upstream server_group {
	    	 server 192.168.xxx.1:8080;
	    	 server 192.168.xxx.2:8080;
	    	 server 192.168.xxx.3:8080;
	    }

    server {
    	 listen       80;
	  
    	 location / {
    		  root   html;
          	  index  index.html index.htm; 
    		  #  代理转发,基于定义的 server_group 配置实现负载均衡
    		  proxy_pass http://server_group; 
    	 }
    }
}

负载参数配置

其中,upstream server_group配置的是负分发服务器组的地址。服务负载默认轮询负载 ,也支持参数化自定义负载配置:weight、backup、max_fails、fail_timeout 等。例如:

csharp 复制代码
upstream server_group {
	 server 192.168.xxx.1:8080 backup;
	 server 192.168.xxx.2:8080 weight=1;
	 server 192.168.xxx.3:8080 max_fails=3 fail_timeout=15s;
}
轮询默认

该策略会将每个请求按时间顺序逐一分配到不同的后端服务器,如果某个后端服务器 down 掉,自动从轮询列表中剔除该服务。

权重(weight)

该策略指定每个服务的权重比例,权重越高被分配的客户端(请求)也就越多,weight 和访问比率成正比。

weight :指定轮询权值,默认值为1。常用于服务主机性能不统一,将性能好的主机分配高权重来发挥服务器最大性能。

down:表示当前的server暂时不参与负载均衡。

fail_timeout:单位为秒,默认是10秒。指定一段时间内,请求经历了max_fails次失败后,该server不能访问的时间(暂停服务的时间)。max_fails可以和fail_timeout一起使用:预留的备份机器。当其他所有的非backup机器故障或忙时,才会请求backup机器,因此这台机器的压力最轻。

max_fails:在fail_timeout时间范围内,允许请求的最大失败次数,默认为1。当达到最大失败次数时,会在fail_timeout时间内不再次被选择,返回 proxy_next_upstream 模块定义的错误。

fail_timeout:单位为秒,默认是10秒。在指定时间内,请求max_fails次失败后,该server不能访问的时间(暂停服务的时间)。max_fails和 fail_timeout一起使用。

最少连接(least_conn)

该策略会将请求分配到连接数最少的服务上。

bash 复制代码
upstream server_group {
	least_conn;
	server 192.168.xxx.1:8080;
	server 192.168.xxx.2:8080; 
}
哈希(ip_hash)

该策略按照每个请求 ip 的 hash 结果分配后端服务器,导致每个访客会固定访问一个后端服务器。可解决了动态网页存在的session共享问题。

地址哈希法:根据获取的客户端ip地址,通过哈希函数计算得到一个定长hash值,然后使用这个值来决定将请求分配给哪台后端服务器。采用源地址哈希法进行负载均衡,同一ip地址的客户端,在后端服务器列表不变情况下,其每次请求都会映射到同一台服务器访问。
哈希值映射:将哈希值映射到可用的后端服务器。通常,哈希值与后端服务器的数量相除并取余数,以次确定要将请求分配到哪台服务器。

例如:如果有3台后端服务器,哈希值为12,则计算:12 % 3 = 0,那么请求将路由到第一台后端服务器

。

bash 复制代码
upstream server_group {
	ip_hash;
	server 192.168.xxx.1:8080;
	server 192.168.xxx.2:8080; 
}

转发请求头配置

csharp 复制代码
location / {
	root   html;
     	index  index.html index.htm; 
	# 代理转发,基于定义的 server_group 配置实现负载均衡
	proxy_pass http://server_group; 
	
		proxy_set_header Host $host:$server_port;
	proxy_set_header X-Real-IP $remote_addr;
	proxy_set_header X-Real-PORT $remote_port;
	proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
}
相关推荐
再吃一根胡萝卜20 分钟前
给 RAG 问答加上「多轮指代消解」:让"他 / 这个"不再翻车
后端
天天喝旺仔1 小时前
gRPC 底层原理:HTTP/2 多路复用、Protobuf 序列化与四种流模式
分布式·http·微服务·rpc
Wx-bishekaifayuan1 小时前
springboot生活易购超市管理系统54086-计算机课程设计、毕业设计
spring boot·后端·python·django·课程设计·express·旅游
lizhongxuan1 小时前
VirtIO:虚拟机的磁盘、网络与内存是怎样工作的
后端
计算机毕设定制辅导-无忧学长2 小时前
《基于Spring Boot的减脂轻食购物网站》
java·vue.js·spring boot·后端·减脂轻食购物网站
沐欣工作室_lvyiyi2 小时前
基于SpringBoot的博物馆预约系统设计与实现(论文+源码)
java·spring boot·后端·计算机毕业设计
拾光记2 小时前
Maven依赖与类加载机制
后端
迪丽热爱3 小时前
HTTP Error 500.30 - ASP.NET Core app failed to start
后端·asp.net
茉莉玫瑰花茶3 小时前
GO [ 函数 ]
开发语言·后端·golang
QuZhengRong3 小时前
【Spring】后端接收的请求参数多了一个逗号的处理办法
java·后端·spring