7-4 sdut-C语言实验-单链表中重复元素的删除
分数 20
全屏浏览
切换布局
作者 马新娟
单位 山东理工大学
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
输入格式:
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。
输出格式:
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
输入样例:
10
21 30 14 55 32 63 11 30 55 30
输出样例:
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
栈限制
8192 KB
cpp
#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node*next;
};
int main()
{
struct node*p,*head,*q,*t;
int n,i,a;
scanf("%d",&n);
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
for(i=0;i<n;i++)
{
p=(struct node*)malloc(sizeof(struct node));
p->next=head->next;
scanf("%d",&p->data);
head->next=p;
}
printf("%d\n",n);
p=head->next;
while(p)
{
if(p->next)
{
printf("%d ",p->data);
}
else{
printf("%d\n",p->data);
}
p=p->next;
}
t=head->next;
while(t)
{
p=t;
q=t->next;
while(q)
{
if(q->data==t->data)
{
p->next=q->next;
q=q->next;
n--;
}
else{
q=q->next;
p=p->next;
}
}
t=t->next;
}
printf("%d\n",n);
p=head->next;
while(p)
{
if(p->next)
{
printf("%d ",p->data);
}
else{
printf("%d\n",p->data);
}
p=p->next;
}
return 0;
}