hadoop服务器启动后无法执行hdfs dfs命令

集群启动后,无法正常使用hdfs的任何命令。使用jps查看进程,发现namenode没有启动,然后再进入到Hadoop的相应目录,打开里面的logs文件

打开Hadoop的master的log

再使用vi编辑器查看(也可以用less或者more命令查看),往上翻到第一个java的报错,发现是img文件坏掉了导致namenode启动不了。然后删除掉hadoop文件下面的tmp文件和dfs文件(子目录也要删干净)。然后重新建dfs和tmp文件,dfs文件下有两个子目录。

然后重新执行namenode -format指令初始化集群。

再重新启动,namenode就可以使用了

可能的原因:namenode死掉的原因可能是关虚拟机时没有stop-all.sh,而是直接把虚拟机关了,导致img出了问题。

相关推荐
小小小米粒33 分钟前
重置本地git
大数据·git·elasticsearch
梦想画家1 小时前
SQLMesh 告警落地实践:SQL 模型跑挂了,如何自动发邮件并推送自建业务系统
大数据·数据开发·sqlmesh
大大大大晴天1 小时前
每天认识一个组件:Apache Calcite
大数据
adinnet20261 小时前
保单、赔付与渠道问数:保险经营数据如何实现按需查询
大数据·数据库·人工智能
53488736abcdefg2 小时前
Hive 入门&架构原理
hive·hadoop·架构
组工部管理能手李哥3 小时前
政务办公场景下,私有化知识库+智能体方案的技术实践与思考
大数据·人工智能
anxiao_m3 小时前
水利数字孪生怎么选?主流可视化渲染平台深度横向测评
大数据·前端·人工智能·图形渲染·云渲染
用户3610588626123 小时前
Flink Time 之时间语义深度剖析:从 Processing Time 到 Event Time 与 Watermark 机制
大数据·flink
梦想画家4 小时前
SQLMesh 宏实现循环完全指南:@EACH、Python 宏与 SQLGlot 表达式实战
大数据·数据开发·sqlmesh
跨境联盟5 小时前
行业思考|精准营养会成为社区健康驿站的核心竞争力吗?
大数据·人工智能·健康医疗·健康管理·精准营养