hadoop服务器启动后无法执行hdfs dfs命令

集群启动后,无法正常使用hdfs的任何命令。使用jps查看进程,发现namenode没有启动,然后再进入到Hadoop的相应目录,打开里面的logs文件

打开Hadoop的master的log

再使用vi编辑器查看(也可以用less或者more命令查看),往上翻到第一个java的报错,发现是img文件坏掉了导致namenode启动不了。然后删除掉hadoop文件下面的tmp文件和dfs文件(子目录也要删干净)。然后重新建dfs和tmp文件,dfs文件下有两个子目录。

然后重新执行namenode -format指令初始化集群。

再重新启动,namenode就可以使用了

可能的原因:namenode死掉的原因可能是关虚拟机时没有stop-all.sh,而是直接把虚拟机关了,导致img出了问题。

相关推荐
归秋14243 分钟前
2026企业AI办公工具选型指南:从场景匹配到平台评估
大数据·运维·人工智能
智圣新创011 小时前
教育数据要素流通刚需下 智圣新创高校数据中台解决方案的全域建设落地框架
大数据·人工智能·物联网
XLYcmy1 小时前
PDF 论文处理器 — 优势与功能文档
大数据·python·网络安全·pdf·dify·rag·漏洞检测
互联网资讯1 小时前
本地创业者入局 AI 短剧,本地化部署怎么选更省钱
大数据·人工智能
小猴子爱上树2 小时前
跨马翻译:批量图片翻译+视频字幕+智能抠图,跨境电商在线图片翻译工具
大数据·人工智能·python·音视频
W***25922 小时前
2026 企业 AI 办公工具怎么选:选型框架与平台全景分析
大数据·人工智能
yl45302 小时前
内蒙热门的废酸再生处理企业
大数据·python
库拉镜像AI牛牛3 小时前
漫剧工作室量产方案:依托知漫剧 AI 短剧降本增效
大数据·服务器·前端·人工智能·语音识别
用户3610588626123 小时前
Flink Sliding Window 详解及代码实现:从窗口重叠到状态爆炸防控
大数据·flink
2601_967212723 小时前
灵活扩展型电源轨道系统服务商技术路线对比与选型参考
大数据·经验分享