linux最大线程数限制及打开最大文件数

1.root用户下执行 ulimit -a 然后查看 max user processes 这个值通常是系统最大线程数的一半

max user processes:当前用户同时打开的进程(包括线程)的最大个数为

2.普通用户下 ulimit -a 出现的max user processes的值 默认是 /etc/security/limits.d/20-nproc.conf文件中的设置值

注:

soft nproc :单个用户可用的最大进程数量(超过会警告);

hard nproc:单个用户可用的最大进程数量(超过会报错);

soft nofile :可打开的文件描述符的最大数(超过会警告);

hard nofile :可打开的文件描述符的最大数(超过会报错);

一般soft的值会比hard小,也可相等。

/etc/security/limits.d/里面配置会覆盖/etc/security/limits.conf的配置。

只有root用户才有权限修改/etc/security/limits.conf。

如果limits.conf没有做设定,则默认值是1024。

  1. 对于cat /etc/pid/limits中Max open files的修改

我们可以从system.conf修改或者在service文件里限制,只对此服务生效,我们这里以nginx服务为例

3.1 修改system.conf配置文件

其中DefaultLimitNOFILE为设置每个进程可以打开的文件描述符的数量上限

DefaultLimitNPROC为设置用户可以拥有的进程的数量上限

重启服务器以及nginx服务后再次查询

3.2 修改service文件

如果有修改需求建议用第二种,另外

/etc/security/limits.conf的配置,只适用于通过PAM认证登录用户的资源限制,它对systemd的service的资源限制不生效

对于systemd service的资源设置,则需修改全局配置,全局配置文件放在/etc/systemd/system.conf和/etc/systemd/user.conf,同时也会加载两个对应目录中的所有.conf文件/etc/systemd/system.conf.d/.conf和/etc/systemd/user.conf.d/.conf。

相关推荐
ShineWinsu1 分钟前
对于Redis:Redis特性以及应用场景的解析
linux·c++·redis·缓存·高并发·分布式系统·key-value
亚川楼宇自控系统数据中心厂家4 分钟前
3D 数字孪生赋能电气综合保护监控:看得见的电力安全防线
运维
北冥有鱼被烹6 分钟前
NVIDIA DGX/HGX 服务器全景深度解析:从 H100 到 GB300,专业算力选型必读
运维·服务器·网络·python
程序员-Benothing11 分钟前
Linux系统启动流程详解:BIOS/UEFI、GRUB、initramfs、systemd
linux·运维·服务器
KKKlucifer14 分钟前
从规则堆叠到策略涌现:AI大模型驱动的数据安全智能策略生成与自动化响应实践
运维·人工智能·自动化
余槐i19 分钟前
-m 2g 反而更早 OOM:Docker 内存计数与宿主机空闲口径差异
java·linux·docker·性能优化·cgroup
傲世仙尊20 分钟前
线程池收尾-回调单例与可重入线程安全
linux·安全
风华同学25 分钟前
Docker镜像换源
运维·docker·容器
牢姐与蒯1 小时前
Linux信号(二).信号产生续 && 信号保存
linux·运维·服务器·ubuntu
何中应1 小时前
Jenkins 如何给设置公司 Logo
运维·ci/cd·jenkins