linux最大线程数限制及打开最大文件数

1.root用户下执行 ulimit -a 然后查看 max user processes 这个值通常是系统最大线程数的一半

max user processes:当前用户同时打开的进程(包括线程)的最大个数为

2.普通用户下 ulimit -a 出现的max user processes的值 默认是 /etc/security/limits.d/20-nproc.conf文件中的设置值

注:

soft nproc :单个用户可用的最大进程数量(超过会警告);

hard nproc:单个用户可用的最大进程数量(超过会报错);

soft nofile :可打开的文件描述符的最大数(超过会警告);

hard nofile :可打开的文件描述符的最大数(超过会报错);

一般soft的值会比hard小,也可相等。

/etc/security/limits.d/里面配置会覆盖/etc/security/limits.conf的配置。

只有root用户才有权限修改/etc/security/limits.conf。

如果limits.conf没有做设定,则默认值是1024。

  1. 对于cat /etc/pid/limits中Max open files的修改

我们可以从system.conf修改或者在service文件里限制,只对此服务生效,我们这里以nginx服务为例

3.1 修改system.conf配置文件

其中DefaultLimitNOFILE为设置每个进程可以打开的文件描述符的数量上限

DefaultLimitNPROC为设置用户可以拥有的进程的数量上限

重启服务器以及nginx服务后再次查询

3.2 修改service文件

如果有修改需求建议用第二种,另外

/etc/security/limits.conf的配置,只适用于通过PAM认证登录用户的资源限制,它对systemd的service的资源限制不生效

对于systemd service的资源设置,则需修改全局配置,全局配置文件放在/etc/systemd/system.conf和/etc/systemd/user.conf,同时也会加载两个对应目录中的所有.conf文件/etc/systemd/system.conf.d/.conf和/etc/systemd/user.conf.d/.conf。

相关推荐
ajassi20002 小时前
AI语音智能体开发日记(十八)智能体服务器xiaozhi-esp32-server源码部署指南
运维·服务器·人工智能·ai·ai编程
‎ദ്ദിᵔ.˛.ᵔ₎2 小时前
linux 进程信号(下)
linux·运维·服务器
skywalk81633 小时前
在FreeBSD系统的linux仿真环境下安装和使用kiro 这个亚马逊的AI agent
linux·人工智能·freebsd·kiro
Mikko73 小时前
Linux 磁盘满了但 du 找不到?LVM 扩容 df 不变?fstab 写错开不了机?三台真机实测磁盘排查
linux·运维·centos
蓝胖的四次元口袋3 小时前
Jenkins知识梳理(2)
运维·jenkins
yumgpkpm3 小时前
Acceldata ODP 3.3.6.4 vs CDP Private Cloud Base 7.3.2 对比
大数据·运维·服务器·hadoop·华为·zookeeper·hbase
Madison-No73 小时前
多语言聊天大模型--测试报告
linux·git·python·selenium·jmeter·自动化·postman
Liuqy-053 小时前
特殊进程——孤儿、僵尸、守护进程
linux·运维·服务器
流浪0013 小时前
Linux系统篇47——线程(十二) POSIX 信号量与环形队列,把判空判满提前到访问之前
linux·操作系统·线程·信号量·环形队列
咖丨喱4 小时前
【MMC Core + hc16 Host(WiFi SDIO 如何落到控制器)】
linux