Redis:创建集群——[ERR] Sorry, can‘t connect to node 192.168.X.X

解决办法:注释掉bind 127.0.0.1可以使所有的ip访问redis

若是想指定多个ip访问,但并不是全部的ip访问,可以bind

在Redis3.2之后,redis增加了protected-mode,在这个模式下,即使注释掉了bind 127.0.0.1,再访问redisd时候还是报错

修改办法:

复制代码
protected-mode no

绑定IP:

复制代码
sed -i 's/bind 127.0.0.1/bind 192.168.122.1/' redis.conf
sed -i 's/protected-mode yes/protected-mode no/' redis.conf
相关推荐
深度智能Ai5 分钟前
IndexTTS‑2高清音质接口对接文档
数据库
Elastic 中国社区官方博客6 分钟前
Kubernetes attributes processor v1:它对 EDOT Collector 意味着什么
java·大数据·elasticsearch·搜索引擎·贪心算法·kubernetes·全文检索
Sarvartha11 分钟前
对象创建与引用
java·开发语言
香瓜子rd21 分钟前
MySQL InnoDB 并发控制核心原理:事务、隔离级别、MVCC 与锁机制
数据库·后端
Elastic 中国社区官方博客1 小时前
Elasticsearch Serverless 如何通过 hollow shards 将索引节点关闭次数降低 30%
大数据·数据库·elasticsearch·搜索引擎·serverless·全文检索
大侠归来1 小时前
C语言与C++在基础语法上的区别
java·c语言·c++
ycvv1 小时前
手机启动失败后的数据提取评估:系统状态、加密条件与文件验收
服务器·数据库·智能手机
小宋10211 小时前
SQL + RAG 混合问答实战:结构化指标与文档证据如何统一路由
java·jvm·人工智能·sql
不恋水的雨1 小时前
gbase中union all导致末尾多出空格的坑
数据库·sql·mysql
bro_Java6661 小时前
链表进阶2:双向链表的构建
java·数据结构·链表