K8s问题案例分析

1.worker节点宕机,请说明一下pod的驱逐流程:

k8s有一个节点控制器,节点控制器在一段时间内无法和kubelet通信,那么就会给节点打上unknown 状态,并自动创建NoExecute污点,避免调度器调度新的pod到该节点。同时已经在这个节点运行的pod,在经过五分钟的容忍时间后被NoExecute自动驱逐。

2.尝试用的日志分析工具在K8s种如何与集群进行通信:

方案一:

一个pod节点部署一个应用容器和边车容器,用共享存储卷emptydir共享两个容器之中的日志目录,边车容器部署这日志收集工具比如:filebeat/fluentd(菲尔安提的)收集共享存储的日志,采集完发送个ESpod集群的service的clusterip,再通过service转发给ES,kibana通过ES的service的cluster访问到es相关的数据进行可视化管理操作。

方案二:

运用hostpath的方法把容器里的日志目录挂载在pod在宿主机的的的目录上,在宿主机上部署filebeat/fluentd 收集日志发送给ESpod集群的service的nodeport(因为时外部宿主机访问),service再转发给ESpod集群,pod容器里的kibana通过ESpod集群的clusterip访问到ES相关的数据进行可视化管理操作。

3. pod启动失败如何解决以及常见的原因有哪些:

没有合适的node节点部署pod,镜像拉取失败,存储券挂载失败,健康检查失败(探针),容器启动失败,启动命令有问题。

4.K8S雪崩:

5.在docker容器里面进行抓包:

kubectl describe pod pod名称 -n 命名空间 -o wide | grep -i 'id'

#获取pod所在的容器id 也就是container id

docker inspect containerid |grep -i pid #根据找到的pid进入pod的网络命名空间

nsenter -t pid号 -n #使用tcpdump进行抓包 #根据找到的pid进入pod的网络命名空间

tcpdump -w xxx.pcap #使用tcpdump进行抓包

相关推荐
寻林写彡5 小时前
01| 裸机部署 K8S:从零搭建生产可用集群
云原生·kubernetes
更深兼春远8 小时前
第2篇:Dify 部署保姆级教程:用 Docker跑起来
docker·容器·dify
小白的码BUG之路12 小时前
Docker -- No space left on device
运维·docker·容器
wzq11_66612 小时前
Kubernetes集群——Service篇(详细讲解!!!)
云原生·容器·kubernetes
程序员老陆13 小时前
Docker 命令全景指南:从镜像构建到生产运维
运维·docker·容器
灯澜忆梦1 天前
【minio】#1 | 简介与安装
docker·对象存储·minio
江湖有缘1 天前
3款开源绘图工具整理合集,可Docker一键部署!
docker·容器·开源
TTATTC1 天前
告别协议选型内耗:深入拆解微服务“内部 gRPC + 边界 REST”混合通信架构与 Envoy 转码实战
docker·开源
小匠石钧知2 天前
06_在k8s集群中安装MetalLB实现LoadBalancer
云原生·容器·kubernetes·service·loadbalancer·metallb
troy1282 天前
阿里云 vs 谷歌云:Kubernetes 部署深度对比分析
阿里云·kubernetes·云计算