docker搭建私有仓库

docker搭建私有仓库

服务端

对于持续集成环境的配置,Jenkins会发布大量的微服务, 要与多台机器进行交互, 可以采用docker镜像的保存与导出功能结合SSH实现, 但这样交互繁琐,稳定性差, 而且不便管理, 这里我们通过搭建Docker的私有仓库来实现, 这个有点类似GIT仓库, 集中统一管理资源, 由客户端拉取或更新。

sh 复制代码
docker pull registry:latest
docker run -d -p 5000:5000 --name registry -v /root/docker/registry:/var/lib/registry registry:latest

查看仓库资源,可以访问地址:http://192.168.200.100:5000/v2/_catalog

删除镜像:

sh 复制代码
cd /root/docker/registry/docker/registry/v2/repositories
# 删除想删除的镜像即可
rm -rf 镜像名称

客户端

正常生产环境中使用, 要配置HTTPS服务,从私有仓库拉取(pull)或推送(push)镜像时,Docker 默认会拒绝非加密(HTTP)的连接。内部开发或测试集成的局域网环境,可以采用简便的方式, 不做安全控制。

设置运行http请求拉取或推送镜像:(--insecure-registry 服务端ip:5000也可以配置到daemon.json中)

sh 复制代码
vi /lib/systemd/system/docker.service
# 服务端修改内容如下:这样服务端就可以从私有仓库直接push/pull镜像了
ExecStart=/usr/bin/dockerd --insecure-registry 服务端ip:5000
# 客户端修改内容如下:这样客户端就可以直接从私有仓库pull/poll镜像了
ExecStart=/usr/bin/dockerd --insecure-registry 服务端ip:5000
# 重启生效
systemctl daemon-reload
systemctl restart docker
相关推荐
智能运维指南44 分钟前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123451 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人1 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender1 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
zly35002 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南2 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
春天花会开1313 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生
当下新鲜事3 小时前
脱硫脱硝塔动力系统科普:四方DL500变频器工作原理解析
大数据·运维·物联网·业界资讯
Lsetea3 小时前
Nginx报No required SSL certificate was sent:mTLS客户端证书排查
运维·nginx·https·ssl·openssl
山岚的运维笔记4 小时前
mysql 专业笔记 -- 第 36 章:MySQL 管理
运维·数据库·笔记·后端·mysql·oracle·dba