exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
C++ 老炮儿的技术栈几秒前
C++ const 的3个核心作用
服务器·c语言·c++·算法·c
进击的荆棘1 分钟前
Linux系统——库的原理与制作之制作和使用动静态库
linux·动静态库
论文复现现场2 分钟前
8卡 A100 服务器哪里租?NVLink、RDMA 与 NCCL 验收指南
linux·服务器·php·分布式训练·rdma·nvlink·nccl
派小心.4 分钟前
多端数据分析平台的漏斗可以跨端搭建吗?5 步搭出跨端转化漏斗
大数据·运维·服务器·前端·数据分析
芷栀夏8 分钟前
极空间部署Photopea:Docker运行、网页修图与多设备使用
运维·docker·容器
见闻小天地12 分钟前
数据中心柴发出口保护怎么选?Emax 与 Tmax XT 的定位与分工
大数据·运维·人工智能·业界资讯
迈威通信27 分钟前
迈威 MISCOM8212GP-4XGF-8GTPoE90-DC48 接入层实践:高密度 PoE++ 与万兆上行的整合方案
运维·网络·信息与通信
小小的木头人28 分钟前
CentOS 7.9 离线安装 NVIDIA Container Toolkit:1.14.0 与 1.20.1 两种版本方案
linux·运维·centos
哭哭啼32 分钟前
Linux 资源紧缺模拟:CPU、内存、磁盘与文件描述符压力测试
linux·运维·压力测试
酒神dnspup42 分钟前
多地区网站可用性监控怎么做?DNSPup 从基线到告警的完整实战
运维·ios·云计算·iphone·dns·网络监控