exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
爱签AI电子合同4 小时前
电子合同上手成本怎么测?易用性维度专项测评
服务器·人工智能·智能合约·企业微信
aixingkong9217 小时前
Nvidia为例 XPU的Multi-Host、Socket Direct 、GPUDirect、RDMA 技术点分析
服务器·网络·硬件架构·硬件工程
雯宝9 小时前
mnt_init 函数
linux
Thneonl15 小时前
Flink Operator 的隐藏陷阱:容器名不是你以为的那个
安全·kubernetes
律宏阔15 小时前
WSL Docker 端口明明空闲,但就是绑不上端口
linux·windows
Thneonl15 小时前
kubectl scale ds 是个 404:DaemonSet 没有 replicas
安全·kubernetes
律宏阔15 小时前
WSL 突然断网,无法 ping 内网或外网
linux·windows
穷人小水滴15 小时前
用容器编译 VirtualBox 虚拟机软件 (ArchLinux, podman)
linux·容器·virtualbox
乱码三千15 小时前
如何优雅地直连无公网 IP 的远程 GPU 服务器
linux·人工智能·程序员
yunwei3715 小时前
使用 eBPF 跟踪 Nginx 请求
linux·后端·性能优化