exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
代码方舟4 分钟前
零信任架构实战:基于天远人企关联构建自动化供应链金融网关
运维·人工智能·架构·自动化
lisanmengmeng27 分钟前
nacos nrpe 监控机及被监控机部署
服务器·nacos·nagios·nrpe
贵沫末1 小时前
Ubuntu——常用软件安装
linux·运维·ubuntu
Doraemomo1 小时前
Linux内核驱动开发——中断与定时器
linux·运维·驱动开发
2301_808414382 小时前
Linux中动静态库的理解
linux·运维·服务器
誰能久伴不乏2 小时前
保姆级 Docker 入门教程
docker·容器·eureka
分布式存储与RustFS2 小时前
模型 checkpoint 放对象存储:分片上传、断点续传与残留清理
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
M78佐菲3 小时前
ARM学习笔记(11)
linux·arm开发·笔记·嵌入式硬件·学习
M78佐菲3 小时前
ARM学习笔记(10)
linux·arm开发·笔记·嵌入式硬件·学习
半仙白桑3 小时前
内核篇第十五讲:system-V共享内存
linux·共享内存·shmget·shmat·shmdt·shmctl