exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
PellyKoo34 分钟前
【linux运维】ubuntu+samba 用户组独占目录权限配置踩坑记
linux·运维·ubuntu
wtblszn35 分钟前
空压机在线监测物联网方案
大数据·运维·物联网·自动化·能源
AR-26710-41 分钟前
Linux Day15——系统管理复习
linux·运维
高山有多高1 小时前
【Linux笔记】Linux自定义Shell
linux·c++
姜鱼问生1 小时前
HTTPS 部署实战:未备案域名 + 非标端口的完整方案
linux·https
jackletter2 小时前
linux:安装 ubuntu 26.04.1
linux·ubuntu·ubuntu26.04.1
打工仔折腾 AI2 小时前
飞牛OS上用Docker Compose部署ExerciseDiary运动记录并配置远程访问
运维·人工智能·后端·python·docker·容器·ai agent 实战
2401_869769592 小时前
make 进度条
linux
天远数科2 小时前
零信任架构实战:基于天远运营商三要素简版V即时版查询构建自动化买手实名核验网关
运维·人工智能·架构·自动化
天衍四九-2 小时前
Docker Compose企业实战系列(八·终章):多环境隔离实战,开发/测试/生产一键切换
运维·docker·容器