exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
一个风轻云淡1 小时前
GCC 和 GDB命令简单解读
java·linux·前端
H.莓飛1 小时前
【数据结构】二叉树_OJ题
linux·开发语言·数据结构·算法
资料库011 小时前
Linux 8个常见运维故障排查
java·linux·运维
谢亮_vipxieliang1 小时前
Kubernetes 1.36 深度解读:从 kubelet 安全到 GPU 原生调度的 70 项改进
安全·kubernetes·kubelet
机核研创社2 小时前
睡裤明橡筋自动化选型指南与落地四步走
运维·自动化
志栋智能2 小时前
超自动化运维,告别复杂系统的新范式
运维·自动化
零基础1232 小时前
Ubuntu 常用命令汇总
linux·运维·开发语言
Android系统攻城狮3 小时前
Linux Gstreamer深度解析之gst_audio_sink_get_type调用流程与实战(六十五)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
xiaoqiMikko3 小时前
Linux 实战(一):CentOS 7、Rocky 9、Ubuntu 24.04 三台真机实测 —— 认清系统、换源、装包的版本坑
linux·centos
迷途之人不知返3 小时前
【基础IO】-1-预备知识与准备工作
linux