exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
顺风尿一寸21 分钟前
手写迷你 Docker:用 Namespace + Cgroup v2 实现一个简单容器
linux
一木 之林36 分钟前
DeepSeek Agent 开发(三)
java·大数据·linux
打工仔折腾 AI1 小时前
Docker镜像分层与卷挂载到底怎么工作:一次文件系统层面的实测分析
运维·人工智能·后端·python·docker·容器·性能优化
大猫会长2 小时前
调用codebuddy集成的supabase授权白屏解决方法
linux·运维·服务器
羔羊++2 小时前
29_实验二十八_buildroot配置与编译
linux
夜之眷属2 小时前
服务器被挖矿病毒入侵的排查与清理实录
运维·服务器
LoneEon2 小时前
CentOS7 部署 Nacos3.x 集群实战:从注册中心到 AI 管理中心
linux·人工智能·nacos
极客先躯2 小时前
高级java每日一道面试题-2026年01月20日-实战篇[Docker]-如何实现镜像的跨区域复制?
java·运维·docker·容器·架构图
dawnsky.liu2 小时前
OpenShift - 实现系统负载和业务负载分区隔离
kubernetes·openshift
传人3 小时前
为什么 Xshell 中可以通过java -version查询到java 版本号码,Electerm 却查不到?
java·linux·服务器