exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
2601_962885724 小时前
如何用 Python 统计 A 股连续涨停(几连板)?
java·linux·python
2401_868534784 小时前
存储系统规划设计
运维·服务器·智能路由器
Ivanqhz4 小时前
KV Cache
服务器·数据库·人工智能·深度学习·算法
JavaPub-rodert4 小时前
Docker 镜像地址总失效?基于 DockerHub 项目用 GitHub Actions 做一个自动检测状态页
docker·容器·github
H.莓飛4 小时前
【数据结构】二叉树
linux·数据结构·算法
螺蛳粉 螺蛳粉4 小时前
第一篇:Keepalived 高可用实战:VIP 漂移与 Nginx 主备切换完整指南
运维·nginx·负载均衡·keepalived·高可用
荣合技术服务4 小时前
VMware ESXi 虚拟化平台服务器虚拟机数据恢复服务
linux·运维·服务器
杭州领祺科技4 小时前
保信子站深度解析:继电保护信息采集与故障诊断的关键枢纽
linux·服务器·网络·新能源·储能·虚拟电厂
xh didida4 小时前
Linux -- 进程概念
linux·服务器·开发语言·c++
爱吃香菜的初学者4 小时前
十三.Linux——信号量
linux·运维·服务器·开发语言