exec /kube-webhook-certgen: exec format error

bash 复制代码
kubectl logs -n ingress-nginx   ingress-nginx-admission-patch-ww2k4
exec /kube-webhook-certgen: exec format error

原因:服务器是x86架构,我本地虚拟机是arm架构。运行 Docker 时,默认情况下会尝试拉取并运行与系统架构匹配的镜像(即 ARM64 架构的镜像)。然而,如果镜像仓库中没有适用于 ARM64 的镜像版本,Docker 可能会拉取并尝试运行 x86 架构的镜像。

可以使用--platform linux/amd64(arm64)指定x86_64(arm64)架构的镜像

docker pull --platform linux/amd64 registry.k8s.io/ingress-nginx/controller:v1.11.2

相关推荐
海宇大数据5 分钟前
零信任架构实战:基于海宇车辆出险记录核验构建自动化二手车收车评估网关
运维·人工智能·架构·自动化
流浪00111 分钟前
Linux系统篇42——线程(七) pthread库管理线程的工作流,从创建到回收
linux·操作系统·线程·线程创建到销毁
Lsetea22 分钟前
OpenSSL报path length constraint exceeded:CA层级与pathlen排查
运维·https·ssl证书·openssl·证书链
Dragon~Snow22 分钟前
Linux server CentOS stream 10系统构建
linux·运维·centos
霞姐聊IT30 分钟前
服务器RAS软件开发经验分享——从Linux、BMC与BIOS三个层面谈工程实践(二)
linux·服务器
bllovepigpig38 分钟前
操作系统个人学习笔记(四):K8s基础
笔记·学习·kubernetes
智商偏低40 分钟前
【无标题】
服务器·数据库·oracle
高山有多高1 小时前
【Linux笔记】Linux磁盘文件系统
linux
千舟软件1 小时前
【宿舍管理·产品功能】宿舍水电账单自动算
大数据·运维·科技·安全·业界资讯
几何心凉1 小时前
嵌入式Linux系统开发21天速成:从基础开发到综合项目实战
linux·运维·服务器