FreeBSD 的Ubuntu jail里启动mysql服务器失败的解决方法

在FreeBSD 的jail里安装Ubuntu后,一直没有尝试安装mysql服务器,网上也没有找到相应的文档(这证明要么太难,天底下就没有解决方案;要么太容易,以至于显而易见,所以不需要文档)。

今天终于被迫,要解决这个问题!

首先,在Ubuntu jail里安装mysql server

直接使用apt安装即可:

复制代码
apt install mysql-server

安装好之后,跟普通Ubuntu系统里不一样,没有自动启动mysql服务(也许这里记错了)

普通Ubuntu系统里,启动mysql服务非常简单,直接执行:

复制代码
systemctl start mysql
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

报错,使用 systemctl status mysql命令也是报错:

systemctl status mysql

System has not been booted with systemd as init system (PID 1). Can't operate.

Failed to connect to bus: Host is down

系统没有使用 systemd 作为初始化系统(init system)

最终使用如下命令启动服务:

复制代码
service mysql start

再看看服务器状态:

复制代码
service mysql status
 * /usr/bin/mysqladmin  Ver 8.0.39-0ubuntu0.22.04.1 for Linux on x86_64 ((Ubuntu))
Copyright (c) 2000, 2024, Oracle and/or its affiliates.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Server version		8.0.39-0ubuntu0.22.04.1
Protocol version	10
Connection		Localhost via UNIX socket
UNIX socket		/var/run/mysqld/mysqld.sock
Uptime:			12 min 11 sec

Threads: 2  Questions: 10  Slow queries: 0  Opens: 438  Flush tables: 3  Open tables: 27  Queries per second avg: 0.013

终于在Ubuntu jail里启动mysql服务拉!

相关推荐
emo_2b7 分钟前
Pycharm配置conda解释器时遇到的问题及解决方法
linux·pycharm·conda
科技研学社21 分钟前
中小服装工装厂自动化改造:产线节拍平衡与工位减负实施方案
运维·自动化
极光通讯24 分钟前
服务器内存替代料选型方法论:主料号缺货时如何找到Pin-to-Pin兼容型号
运维·服务器
草根大哥24 分钟前
08-横向扩容与突发高并发:加机器到底买到了什么
运维·webrtc·srt·横向扩容·whip·自建cdn
人生百态,人生如梦39 分钟前
Ubuntu在低版本下使用ccswitch+claudecode(CCSwitch+Docker+Claude)连调教程
linux·ubuntu·docker·claudecode·ccswitch
oicola44 分钟前
【运维】CI/CD是什么,合格的规范应该怎么设置
运维·ci/cd
Dachui_11221 小时前
内网穿透如何限制访问地区?ZeroNews Geo Location 区域访问控制实践
运维·网络安全·内网穿透·访问控制·远程办公·api安全·ip白名单
byte轻骑兵1 小时前
【BlueZ】hciconfig 工具:蓝牙适配器管理实操 + 源码实现基础
linux·bluez·电脑蓝牙·嵌入式蓝牙
SKH.1 小时前
Linux驱动-系统移植
linux·服务器
根目录下的猫1 小时前
虚拟机复制过来运行时:“虚拟机使用的此版本,VMware Workstation 不支持的硬件版本。”错误解决办法,亲测可用
linux·运维·服务器·后端