Ubuntu环境切换到服务器某个用户后source等命令和Tab快捷补全都用不了了,提示没找到,但root用户可以

以escs用户为例:

输入以下命令

grep root /etc/passwd

grep escs /etc/passwd

对比发现,root用户配的是bash,而escs却是sh,

所以把escs的sh改成和root一样的bash,命令为

usermod -s /bin/bash escs

改好后就可以了。

但一些快捷命令比如ls -l的快捷命令ll不能使用的话则需要去该用户的.bashrc配置文件里加上相应的配置才行。

相关推荐
vortex53 分钟前
常用终端模拟器全面对比:Kitty、WezTerm、Ghostty 与 Konsole
linux
我命由我123459 分钟前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人10 分钟前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender30 分钟前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
Wang's Blog1 小时前
Java 项目实战: 外卖平台-删除分类的关联校验与自定义业务异常
java·服务器·项目开发
INGNIGHT1 小时前
270 · 电话号码的字母组合II(Trie)
linux·算法
zly35001 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
智能运维指南1 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
学习中的码虫2 小时前
网络编程5
服务器·网络
春天花会开1312 小时前
Supabase 自部署 Edge Functions 超时从 60s 延长到 360s 完整复盘
运维·云原生