L2-004 这是二叉搜索树吗?

一棵二叉搜索树可被递归地定义为具有下列性质的二叉树:对于任一结点,

  • 其左子树中所有结点的键值小于该结点的键值;
  • 其右子树中所有结点的键值大于等于该结点的键值;
  • 其左右子树都是二叉搜索树。

所谓二叉搜索树的"镜像",即将所有结点的左右子树对换位置后所得到的树。

给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

输入格式:

输入的第一行给出正整数 N(≤1000)。随后一行给出 N 个整数键值,其间以空格分隔。

输出格式:

如果输入序列是对一棵二叉搜索树或其镜像进行前序遍历的结果,则首先在一行中输出 YES ,然后在下一行输出该树后序遍历的结果。数字间有 1 个空格,一行的首尾不得有多余空格。若答案是否,则输出 NO

输入样例 1:

7
8 6 5 7 10 8 11

输出样例 1:

YES
5 7 6 8 11 10 8

输入样例 2:

7
8 10 11 8 6 7 5

输出样例 2:

YES
11 8 10 7 5 6 8

输入样例 3:

7
8 6 8 5 10 9 11

输出样例 3:

NO

solution:

cpp 复制代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
vector<int>a;
vector<int>pre,premir,post,postmir;
#define null NULL
struct node
{
	int val;
	node *left;
	node *right;
};
void build(node* &t,int x)
{
	if(t==null)
	{
		t=new node();
		t->val=x;
		t->left=null;
		t->right=null;
		return;
	}
	if(t->val<=x)build(t->right,x);
	else build(t->left,x);
}
void preorder(node *t)
{
	if(t==null)return;
	pre.push_back(t->val);
	preorder(t->left);
	preorder(t->right);
}
void premirorder(node *t)
{
	if(t==null)return;
	premir.push_back(t->val);
	premirorder(t->right);
	premirorder(t->left);
}
void postorder(node *t)
{
	if(t==null)return;
	postorder(t->left);
	postorder(t->right);
	post.push_back(t->val);
}
void postmirorder(node *t)
{
	if(t==null)return;
	postmirorder(t->right);
	postmirorder(t->left);
	postmir.push_back(t->val);
}
int main()
{
	int n;cin>>n;
	node *root=null;
	for(int i=0;i<n;i++)
	{
		int x;cin>>x;
		a.push_back(x);
		build(root,x);
	}
	premirorder(root);
	preorder(root);
	if(a==pre)
	{
		cout<<"YES"<<endl;
		postorder(root);
		for(int i=0;i<post.size();i++)
		{
			if(i)cout<<' ';
			cout<<post[i];
		}
		cout<<endl;
	}
	else if(a==premir)
	{
		cout<<"YES"<<endl;
		postmirorder(root);
		for(int i=0;i<postmir.size();i++)
		{
			if(i)cout<<' ';
			cout<<postmir[i];
		}
		cout<<endl;
	}
	else cout<<"NO"<<endl;
}
相关推荐
青い月の魔女18 分钟前
数据结构初阶---二叉树
c语言·数据结构·笔记·学习·算法
我要出家当道士44 分钟前
Nginx单向链表 ngx_list_t
数据结构·nginx·链表·c
林的快手1 小时前
209.长度最小的子数组
java·数据结构·数据库·python·算法·leetcode
FeboReigns1 小时前
C++简明教程(4)(Hello World)
c语言·c++
FeboReigns1 小时前
C++简明教程(10)(初识类)
c语言·开发语言·c++
千天夜1 小时前
多源多点路径规划:基于启发式动态生成树算法的实现
算法·机器学习·动态规划
zh路西法1 小时前
【C++决策和状态管理】从状态模式,有限状态机,行为树到决策树(二):从FSM开始的2D游戏角色操控底层源码编写
c++·游戏·unity·设计模式·状态模式
从以前1 小时前
准备考试:解决大学入学考试问题
数据结构·python·算法
.Vcoistnt2 小时前
Codeforces Round 994 (Div. 2)(A-D)
数据结构·c++·算法·贪心算法·动态规划
小k_不小2 小时前
C++面试八股文:指针与引用的区别
c++·面试