使用ubuntu On windows安装docker

最近需要做一下springcloud研发,不想装一堆中间件在本地,想跑一下docker,docker desktop不太好用,想直接跑linux虚拟机,有不响装vmware,就像试用下unbuntu On windows。据说可以直接用cmd命令行跑。

方法如下:

  1. 打开windows应用商店。
  1. 搜索unbuntu并安装一个版本,我这里装了24.04.1最新版。

  2. 启动unbuntu on windows,会弹出一个cmd窗口,其实是连接了windows内置wsl的ubuntu系统。首次打开要等初始化。

之后就这个界面了。其实和连接到unbuntu控制台类似,但是使用还是有限制。例如不能使用sysctl做管理,需要用service。而且很多权限受限制,很多操作需要sudo。这里不再多说,自己试试吧。对了,需要确保是使用的wsl 2版本。

  1. 安装docker-ce

    #更新包
    sudo apt-get update

    #安装必要的依赖:
    sudo apt-get install -y apt-transport-https ca-certificates curl software-properties-common

    #添加 Docker 的官方 GPG 密钥
    curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo gpg --dearmor -o /usr/share/keyrings/docker-archive-keyring.gpg

    #添加 Docker APT 源
    echo "deb [arch=amd64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/ubuntu $(lsb_release -cs) stable" | sudo tee /etc/apt/sources.list.d/docker.list > /dev/null

    #更新包列表并安装 Docker CE
    sudo apt-get update
    sudo apt-get install -y docker-ce docker-ce-cli containerd.io

    #启动 Docker 服务
    sudo service docker status

注意,这里启动docker可能会有报错,提示iptables的错误。

failed to start daemon: Error initializing network controller: error obtaining

  1. 安装并修改iptables

    #安装iptables
    sudo apt-get update
    sudo apt-get install -y iptables

    #重置iptables规则
    sudo iptables -F
    sudo iptables -t nat -F
    sudo iptables -t mangle -F
    sudo iptables -X

    #将iptables用iptables-legacy替换
    sudo update-alternatives --set iptables /usr/sbin/iptables-legacy

    #开启ipv4转发功能
    sudo sed -i 's/#net.ipv4.ip_forward=1/net.ipv4.ip_forward=1/g' /etc/sysctl.conf`

完成后,退出重启ubuntu on windows的窗口即可。

  1. 启动docker sudo service docker start

  2. 检查docker状态

相关推荐
虎头金猫5 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS5 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
AI职业加油站5 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏5 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
玉&心5 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing5 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
-梅5 天前
linux(8) 软硬链接
linux·运维·服务器
赵文宇(温玉)5 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang5 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren5 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github