mysql 配置文件 my.cnf 增加 lower_case_table_names = 1 服务启动不了

原因:在MySQL8.0之后的版本,只允许在数据库初始化时指定,之后不允许修改了

mysql 配置文件 my.cnf 增加 lower_case_table_names = 1 服务启动不了

报错信息:Job for mysqld.service failed because the control process exited with error code. See "systemctl status mysqld.service" and "journalctl -xe" for details.

具体情况说明:

原来mysql服务正常运行

修改配置文件 my.cnf,简单的增加一行配置信息:lower_case_table_names = 1

配置文件 my.cnf 修改前的内容:

配置文件 my.cnf 修改后的内容:

重启mysql服务失败,报错信息:Job for mysqld.service failed because the control process exited with error code. See "systemctl status mysqld.service" and "journalctl -xe" for details.

原因:在MySQL8.0之后的版本,只允许在数据库初始化时指定,之后不允许修改了

相关推荐
Elastic 中国社区官方博客5 小时前
将你自己的密钥用于现有 Elastic Cloud 部署
大数据·数据库·elasticsearch·全文检索
红海云6 小时前
Jev:给智能系统做判断的模型
大数据·数据库·人工智能
wjkjpcba6 小时前
PCBA烧录程序是什么:PCBA包工包料厂家解析烧录与测试
linux·数据库·人工智能·smt贴片加工·pcba贴片加工厂
꯭自꯭闭꯭6 小时前
达梦事物特性及MVCC
linux·运维·数据库
小马同学-7 小时前
MySQL主从复制和读写分离
数据库·mysql
谢亮_vipxieliang7 小时前
Spring 事务失效的常见场景
java·开发语言·数据库·spring boot
海绵宝宝转agent7 小时前
MySql高频面试八股开源笔记总结
mysql·面试·开源
geovindu8 小时前
sql: JSON and XML Data Handling in SQL using sql server 2025
大数据·数据库·sqlserver·数据库开发·数据库架构
IT大白鼠8 小时前
图数据库系列 · 第 02 篇——架构拆解:原生图存储到因果集群
数据库·架构·nosql
余槐i8 小时前
数据没回滚也不报错:@Transactional 自调用失效的 3 种复现与修复
spring boot·mysql·多线程·spring 事务