ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法

ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法:

日志文件要放在/var/log/named/目录下,比如:/var/log/named/bind.log

/etc/bind/目录下创建named.conf.log文件,内容如下:

bash 复制代码
logging {
        channel bind_log {
                file "/var/log/named/bind.log" versions 3 size 10m;
                severity info;
                print-category  yes;
                print-severity  yes;
                print-time      yes;
        };

        category queries { bind_log; };
};

/etc/bind/named.conf后面添加:

bash 复制代码
include "/etc/bind/named.conf.log";

修改文件用户:

bash 复制代码
chown bind:bind /var/log/named/bind.log

原因是/etc/apparmor.d/usr.sbin.named这个文件中有:

bash 复制代码
/var/log/named/** rw,
/var/log/named/ rw,

你也可以修改成你指定的目录。

相关推荐
左手の明天2 小时前
SLIP 协议封装与解析详解:原理、C 代码与实战案例
linux·c语言·开发语言·c++
꯭自꯭闭꯭2 小时前
达梦SQL优化相关
linux·运维·数据库·sql
一条破秋裤3 小时前
Linux 共享内存通信:POSIX 共享内存与 mmap
linux·运维·服务器
贵州山魈羡民3 小时前
【玩转手机】通过 Podroid 上的 Alpine 部署 1Panel,把微型服务器装进口袋
运维·服务器
谷哥的小弟5 小时前
CentOS Stream浴火重生
linux·运维·centos
程序员-Benothing5 小时前
Shell输入输出详解:read、echo、printf、颜色输出
linux·运维·服务器
FPGA小徐6 小时前
从 NEMU 到 AbstractMachine:程序、运行时环境与 AM 完全解析
linux·运维·服务器
qetfw7 小时前
Debian Chrony 时间同步、RAID5 与 LUKS 磁盘加密配置
linux·debian
东城居士10 小时前
Linux驱动阻塞与非阻塞访问的理解
linux·嵌入式系统
..Dauntless..10 小时前
【Linux】进程地址空间初步理解
linux·运维·服务器