ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法

ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法:

日志文件要放在/var/log/named/目录下,比如:/var/log/named/bind.log

/etc/bind/目录下创建named.conf.log文件,内容如下:

bash 复制代码
logging {
        channel bind_log {
                file "/var/log/named/bind.log" versions 3 size 10m;
                severity info;
                print-category  yes;
                print-severity  yes;
                print-time      yes;
        };

        category queries { bind_log; };
};

/etc/bind/named.conf后面添加:

bash 复制代码
include "/etc/bind/named.conf.log";

修改文件用户:

bash 复制代码
chown bind:bind /var/log/named/bind.log

原因是/etc/apparmor.d/usr.sbin.named这个文件中有:

bash 复制代码
/var/log/named/** rw,
/var/log/named/ rw,

你也可以修改成你指定的目录。

相关推荐
知行EDI16 分钟前
知行之桥 MaBang 端口使用指南——Create Order 订单创建篇
java·服务器·数据库
成旭先生28 分钟前
【2026】企业信息模糊查询 API 实战:名称、注册号、统一社会信用代码、企业类型与法人一次查全
服务器·数据库·数据服务
殷色玫瑰2 小时前
C/C++ 内存管理详解:从内存分布到 new/delete 底层原理
java·linux·c语言·c++
山岚的运维笔记2 小时前
ComfyUI NVIDIA安装教程:官方便携版下载+run_nvidia_gpu.bat启动,8G显存Windows实操
运维·服务器·windows·笔记·prompt·aigc·comfyui
꯭自꯭闭꯭3 小时前
DM7主备升级方案
linux·服务器·数据库
用户4107192013253 小时前
VMware 虚拟机Ubuntu 环境linux远程连接失败
linux
lisanmengmeng3 小时前
Nagios邮件报警的配置
linux·运维·服务器
范什么特西3 小时前
第二段经历
服务器
Ruiery3 小时前
Linux 6.6内核 CPU 深度解析(六):cpufreq
linux·运维·服务器
倔强的石头1063 小时前
【Linux指南】动静态库系列(十一):PLT 与延迟绑定:第一次调用动态库函数时发生了什么
linux·人工智能·python