ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法

ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法:

日志文件要放在/var/log/named/目录下,比如:/var/log/named/bind.log

/etc/bind/目录下创建named.conf.log文件,内容如下:

bash 复制代码
logging {
        channel bind_log {
                file "/var/log/named/bind.log" versions 3 size 10m;
                severity info;
                print-category  yes;
                print-severity  yes;
                print-time      yes;
        };

        category queries { bind_log; };
};

/etc/bind/named.conf后面添加:

bash 复制代码
include "/etc/bind/named.conf.log";

修改文件用户:

bash 复制代码
chown bind:bind /var/log/named/bind.log

原因是/etc/apparmor.d/usr.sbin.named这个文件中有:

bash 复制代码
/var/log/named/** rw,
/var/log/named/ rw,

你也可以修改成你指定的目录。

相关推荐
_upupup2 小时前
Linux的调试工具——gdb/cgdb
linux·服务器
JeJe同学3 小时前
Docker镜像导入、容器启动
linux·运维·docker
Jason_zhao_MR3 小时前
Linux与实时控制如何兼得
linux·嵌入式硬件·机器人·工业控制
闲云野鹤在人间4 小时前
MySQL|从理论、安装、备份到主从复制、MHA高可用详解
linux·运维·数据库·mysql·云计算
一个风轻云淡5 小时前
GCC 和 GDB命令简单解读
java·linux·前端
H.莓飛5 小时前
【数据结构】二叉树_OJ题
linux·开发语言·数据结构·算法
资料库015 小时前
Linux 8个常见运维故障排查
java·linux·运维
零基础1236 小时前
Ubuntu 常用命令汇总
linux·运维·开发语言
Android系统攻城狮6 小时前
Linux Gstreamer深度解析之gst_audio_sink_get_type调用流程与实战(六十五)
linux·运维·服务器·音视频·gstreamer音视频·音视频进阶·gstreamer音视频进阶
xiaoqiMikko6 小时前
Linux 实战(一):CentOS 7、Rocky 9、Ubuntu 24.04 三台真机实测 —— 认清系统、换源、装包的版本坑
linux·centos