ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法

ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法:

日志文件要放在/var/log/named/目录下,比如:/var/log/named/bind.log

/etc/bind/目录下创建named.conf.log文件,内容如下:

bash 复制代码
logging {
        channel bind_log {
                file "/var/log/named/bind.log" versions 3 size 10m;
                severity info;
                print-category  yes;
                print-severity  yes;
                print-time      yes;
        };

        category queries { bind_log; };
};

/etc/bind/named.conf后面添加:

bash 复制代码
include "/etc/bind/named.conf.log";

修改文件用户:

bash 复制代码
chown bind:bind /var/log/named/bind.log

原因是/etc/apparmor.d/usr.sbin.named这个文件中有:

bash 复制代码
/var/log/named/** rw,
/var/log/named/ rw,

你也可以修改成你指定的目录。

相关推荐
wuminyu4 分钟前
ForkJoinPool窃取线程在扫描其他WorkQueue时的随机采样算法与Phase线程挂起唤醒机制解析
java·linux·c语言·jvm·c++
liulilittle21 分钟前
Linux 下 select 测试函数
linux·服务器·网络·数据库·c++·select·c
DongQiShanRen33 分钟前
玄龙(上):TICK 主循环——意识心跳怎么跳
linux·jvm·数据库·人工智能·数据挖掘·rust
小此方36 分钟前
Linux网络(二十一):深入理解 TCP 异常处理:网线断开、Keepalive 保活机制与 Linux 内核传输层协议源码剖析
linux·网络·tcp/ip
pride.li1 小时前
Python 安装
linux·python·ubuntu
笔墨登场说说1 小时前
centos 8 使用 kafka_2.13-4.3.1.tgz 安装kafka
linux·kafka·centos
luo_guibin1 小时前
Linux系统下OpenSSL升级全流程,新旧版本切换
linux·运维·服务器
看着博客敲代码1 小时前
No space left on device:服务器被 SSH 爆破到日志写满的完整排查与止血
linux·运维·服务器·安全·ssh
明日清晨1 小时前
mobaxterm root身份登录Ubuntu
linux·ubuntu·postgresql
沫璃染墨1 小时前
《Linux工程实践篇(二):线程池实战——从线程安全单例到完整源码实现》
linux·开发语言·c++·单例模式·设计模式·系统架构