ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法

ubuntu用bind9自建DNS服务器时logging日志出现failed: permission denied解决方法:

日志文件要放在/var/log/named/目录下,比如:/var/log/named/bind.log

/etc/bind/目录下创建named.conf.log文件,内容如下:

bash 复制代码
logging {
        channel bind_log {
                file "/var/log/named/bind.log" versions 3 size 10m;
                severity info;
                print-category  yes;
                print-severity  yes;
                print-time      yes;
        };

        category queries { bind_log; };
};

/etc/bind/named.conf后面添加:

bash 复制代码
include "/etc/bind/named.conf.log";

修改文件用户:

bash 复制代码
chown bind:bind /var/log/named/bind.log

原因是/etc/apparmor.d/usr.sbin.named这个文件中有:

bash 复制代码
/var/log/named/** rw,
/var/log/named/ rw,

你也可以修改成你指定的目录。

相关推荐
未济3 天前
linux 配置环境变量
linux
傲世仙尊3 天前
目录即文件-Ext文件系统收尾篇
linux·c语言
虎头金猫3 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
_艾伦 耶格尔.3 天前
进程间通信
linux
Liuqy-053 天前
Linux IO编程——静态库、动态库
linux
彧azz3 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
-梅3 天前
linux(8) 软硬链接
linux·运维·服务器
Wang's Blog3 天前
Java 项目实战: 外卖平台-文件下载与ServletOutputStream回写浏览器
服务器·项目开发
AIgorithmGEEK3 天前
[Linux]线程三部曲(上):一个执行流的诞生——从操作系统一路拆到 pthread_create
linux·线程·pid
琥珀色糖3 天前
SimlpeHttp
linux·服务器