linux上jdk1.8安装elasticsearch6.8.5踩坑总结

先在windows上下载了elasticsearch8安装成功后,本来是想在linux上也安装一个一样的版本,然后发现各种启动不了,查了一天原来jdk版本不同,需要下载不同版本的elasticsearch,我测试了8+,7+,6+,发现最合适jdk1.8的是elasticsearch6.8.5;

主要安装命令如下

  1. .下载: wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.8.5.tar.gz

  2. .解压: tar -xzf elasticsearch-6.8.5.tar.gz

  3. 用root用户添加新用户,记得要设置密码,sudo useradd elasticsearch

  4. 修改目录权限:sudo chown -R elasticsearch:elasticsearch elasticsearch-6.8.5

  5. 切换到新用户下启动:

  6. su elasticsearch

    cd elasticsearch-6.8.5/bin

    ./elasticsearch

  7. 也可以后台启动:nohup ./elasticsearch &

  8. 验证是否可以连接:curl -X GET "localhost:9200/"

  9. 如何有防火墙就把9200的端口开放出去

    10.sudo firewall-cmd --zone=public --add-port=9200/tcp --permanent

    sudo firewall-cmd --zone=public --add-port=9300/tcp --permanent

    sudo firewall-cmd --reload

    一般elasticsearch的配置基本上修改能远程访问,network.host: 0.0.0.0

  10. 除了以上正常的命令外,报错

  11. 第一种:max file descriptors 4096  for elasticsearch process is too low, increase to at least 65535

  12. 解决方法:sudo vi /etc/security/limits.conf,添加以下两行,修改都要root用户,否则会显示只读

  13. elasticsearch - nofile 65535

  14. elasticsearch - memlock unlimited

  15. sudo vi /etc/sysctl.conf,添加一行

  16. vm.max_map_count=262144

  17. 应用修改的参数:sudo sysctl -p,再启动elasticsearch

  18. 第二种:Java HotSpot™ 64-Bit Server VM warning: Cannot open file logs/gc.log due to Permission denied

  19. 解决方法:这个是日志文件权限不足,给权限就行。

  20. chown -R elasticsearch:elasticsearch /path/to/elasticsearch-6.8.5/logs,再重启elasticsearch

相关推荐
Felven8 小时前
stress-ng 与 fio 性能测试工具使用指南
linux·测试工具·fio·stress-ng
XiaoMaqqqq9 小时前
市面上正规的IP驱动产业新场景新工具哪家强
运维·python·网络协议·tcp/ip
huainingning9 小时前
RJ SW Console口忘记密码处理方法
linux·运维·服务器
布裘9 小时前
【银河麒麟】桌面系统循环登录,无法进入桌面?
linux·运维·服务器
慧都小项9 小时前
程序到了Linux才出错?用CLion把调试接到目标环境
linux·运维·服务器
Lsetea10 小时前
OpenSSL verify报unhandled critical extension:error 34与关键扩展排查
运维·https·ssl证书·openssl·证书链
guo_wen_qiang10 小时前
docker的备份与迁移
运维·docker·容器
Ruiery12 小时前
Linux 6.6内核内存管理深度解析(一):物理内存初始化 — memblock 怎么把内存交给 buddy
linux·运维·服务器
2401_8685347812 小时前
无线网络规划设计
服务器·网络
库拉镜像AI牛牛12 小时前
短剧内容自动化生产:知漫剧工作室落地教程
大数据·服务器·前端·人工智能·语音识别