题目 2794: 求平均年龄
时间限制: 2s 内存限制: 192MB 提交: 10696 解决: 5505
题目描述
班上有学生若干名,给出每名学生的年龄(整数),求班上所有学生的平均年龄,保留到小数点后两位。
输入格式
第一行有一个整数n(1<= n <= 100),表示学生的人数。第二行共有n个整数,表示每个学生的年龄,取值为15到25,空格分开。
输出格式
输出一行,该行包含一个浮点数,为要求的平均年龄,保留到小数点后两位。
样例输入
2
18 17
样例输出
17.50
cpp
#include <bits/stdc++.h>
using namespace std;
const int N = 101;
int main() {
int n;
int num_array[N];
double average = 0;
cin >> n;
for(int i=1; i<=n; i++) {
cin >> num_array[i];
}
for(int i=1; i<=n; i++) {
average += num_array[i];
}
cout << fixed << setprecision(2) << average / n;
return 0;
}