发布/部署WebApi服务器(IIS+.NET8+ASP.NETCore)

CS软件授权注册系统-发布/部署WebApi服务器(IIS+.NET8+ASP.NETCore)

目录

本文摘要

发布CSFramework.LicenseV3软件授权注册系统的WebApi服务到IIS上,写了这篇完整版文章,分享给大家。

本文内容:

  • VS2022发布.NET8+ASP.NETCore 网站(WebApi服务器)
  • 部署WebApi服务器到IIS服务器
  • 配置dns域名
  • 配置https协议

VS2022配置发布

VS2022发布WebApi

点击【发布】按钮。

IIS服务器部署WebApi

将程序文件复制到云服务器

打开阿里云ECS服务器,在c:\盘建立一个目录,如:demo-webapi-license-v3

将Debug-Publish\目录下所有文件复制到云服务器新建目录下。

添加网站

打开IIS管理器,添加网站:

1、因ECS服务器部署多个Web站点,不能直接使用80端口。

2、配置一个dns域名: license.csframework.com。

配置应用程序池

配置dns域名

主机名使用 license.csframework.com, 需要配置dns域名。

打开阿里云控制台,我的域名,点击解析,添加记录

配置端口

配置http/https两种网站类型:

  • http: 80端口
  • https: 19980端口

在IIS服务器修改WebApi服务器端口:

阿里云ECS服务器配置19980端口

使用阿里云ECS服务器,需要添加自定义端口安全规则。

安全组 -> 管理规则

入方向,手动添加

配置https协议 (申请ssl证书)

首先要在阿里云申请免费ssl证书,每年可以免费申请20个证书,有效期3个月。1年的证书需要收费。

下载证书:

下载证书文件,在ECS服务器上安装证书:

输入密码,下一步,最后点【完成】安装证书。

重点:绑定https,选择ssl证书。

选择正确的ssl证书,如下图所示:

恭喜您,完成配置!

完成配置,重启应用程序池,开始测试api接口和swagger。

测试WebApi服务器

获取服务器时间

https://license.csframework.com:19980/api/license/getservertime

swagger主页

http://license.csframework.com:19980/swagger/index.html

踩坑及解决方案

1、HTTP Error 500.31 - Failed to load ASP.NET Core runtime,Microsoft.NetCore.App or Microsoft.AspNetCore.App was not found.

解决方案:

HTTP Error 500.31 - Failed to load ASP.NET Core runtime,Microsoft.NetCore.App or Microsoft.AspNetCore.App was not found.-开发框架文库

.NET8/ .NETCore /ASP.NETCore 部署WebApi到IIS服务器需要安装的运行环境-开发框架文库

2、.NETCore WebApi发布到IIS服务器无法打开swagger

解决方案:

.NETCore WebApi发布到IIS服务器无法打开swagger-开发框架文库

相关推荐
雪落漂泊20 分钟前
Linux基本指令(上)
linux·运维·服务器
ai小陈1 小时前
GPU服务器租用部署实战:用systemd守护模型推理服务
运维·服务器·人工智能·ai·php·gpu算力
开开心心_Every1 小时前
文件夹批量创建工具支持同级和多层级
运维·服务器·游戏·jupyter·智能手机·pdf·postman
KING-WU5121 小时前
Linux 工具之 yum、vim、gcc
linux·运维·服务器·后端
Mortalbreeze1 小时前
MySQL 基础篇(三):一文掌握 MySQL 常见数据类型
linux·服务器·数据库·mysql
沫璃染墨1 小时前
《从零入门Linux系统篇(五十三):线程篇·六——线程互斥详解:从并发问题到mutex互斥锁》
linux·运维·服务器·开发语言·后端·架构·系统架构
程序员-Benothing1 小时前
Shell循环教程:for、while、until、break、continue详解
linux·运维·服务器
雪落漂泊1 小时前
Linux基本指令(下)
java·linux·服务器
小白的码BUG之路1 小时前
Ubuntu -- 使用命令firewall-cmd
linux·运维·服务器
Chill601 小时前
非root用户怎么在ubuntu服务器上配置第三方的codex
linux·服务器·ubuntu