《算法笔记》9.6小节 数据结构专题(2)并查集 问题 D: More is better

题目描述

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入
复制代码
3
1 3
1 5
2 5
4
3 2
3 4
1 6
2 6
样例输出
复制代码
4
5

题目大意: 房间里有编号从1~10000000共10000000人,每次给出n对关系,每对关系表示这两个人被选中了且成为朋友。问最后被选中的最大朋友人数是多少,如果没有人被选中,则留下1个人;如果有多组朋友,输出最大的组有多少人。

分析:并查集的应用。不过这个集合很大,因此要在合并的时候,记录合并后组的人数。

cpp 复制代码
#include<algorithm>
#include <iostream>
#include  <cstdlib>
#include  <cstring>
#include   <string>
#include   <vector>
#include   <cstdio>
#include    <queue>
#include    <stack>
#include    <ctime>
#include    <cmath>
#include      <map>
#include      <set>
#define INF 0xffffffff
#define db1(x) cout<<#x<<"="<<(x)<<endl
#define db2(x,y) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<endl
#define db3(x,y,z) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<endl
#define db4(x,y,z,r) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<", "<<#r<<"="<<(r)<<endl
#define db5(x,y,z,r,w) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<", "<<#r<<"="<<(r)<<", "<<#w<<"="<<(w)<<endl
using namespace std;

int father[10000005],cnt[10000005];

int findFather(int x,int father[])
{
    int a=x;
    while(father[x]!=x)x=father[x];
    while(a!=father[a])
    {
        int temp=a;
        a=father[a],father[temp]=x;
    }
    return x;
}

void Union(int a,int b,int father[],int cnt[],int &ans)
{
    int faA=findFather(a,father),faB=findFather(b,father);
//    db4(a,b,faA,faB);
    if(faA!=faB)
    {
        father[faA]=faB;
        cnt[faB]+=cnt[faA];
        ans=max(ans,cnt[faB]);
    }
    return;
}

int main(void)
{
    #ifdef test
    freopen("in.txt","r",stdin);
    //freopen("in.txt","w",stdout);
    clock_t start=clock();
    #endif //test

    int T,n,m;
    while(~scanf("%d",&T))
    {
        int ans=-1;
        if(T==0)
        {
            printf("1\n");continue;
        }
        for(int i=1;i<=10000005;++i)
            father[i]=i,cnt[i]=1;
        for(int i=0;i<T;++i)
        {
            scanf("%d%d",&n,&m);
            Union(n,m,father,cnt,ans);
        }
        printf("%d\n",ans);
    }

    #ifdef test
    clockid_t end=clock();
    double endtime=(double)(end-start)/CLOCKS_PER_SEC;
    printf("\n\n\n\n\n");
    cout<<"Total time:"<<endtime<<"s"<<endl;        //s为单位
    cout<<"Total time:"<<endtime*1000<<"ms"<<endl;    //ms为单位
    #endif //test
    return 0;
}
相关推荐
慕容青峰26 分钟前
【蓝桥杯 2025 省 A 扫地机器人】题解
c++·算法·蓝桥杯·sublime text
_yingty_37 分钟前
GO语言入门:常用数学函数2
java·学习·算法·golang
猎猎长风41 分钟前
【数据结构和算法】3. 排序算法
数据结构·算法·排序算法
bookish_2010_prj1 小时前
链式栈和线性栈
数据结构·c++·算法
egoist20231 小时前
【C++指南】哈希驱动的封装:如何让unordered_map/set飞得更快更稳?【上】
数据结构·c++·算法·容器·哈希算法·散列表·c++11
Wang201220132 小时前
随机深林算法是分类还是回归?
算法·分类·回归
@蓝莓果粒茶2 小时前
LeetCode第158题_用Read4读取N个字符 II
前端·c++·python·算法·leetcode·职场和发展·c#
Heisenberg~2 小时前
C++回溯算法详解
开发语言·c++·算法
骑驴看星星a2 小时前
P10416 [蓝桥杯 2023 国 A] XYZ
算法·职场和发展·蓝桥杯
又过一个秋2 小时前
【sylar-webserver】重构日志系统
linux·c++·算法·重构