tomcat Server 连接服务器 进展

由于机房的环境变更,所接触的问题也不一样!!!!

但后来出现以下提示:

复制代码
已连接到服务器
配置错误: 部署源 'springmvc:war' 无效[2025-04-23 11:19:50,192] 工件 springmvc:war: 部署工件时出错。请参阅服务器日志了解详细信息。
配置错误: 部署源 'springmvc:war exploded' 无效[2025-04-23 11:19:50,192] 工件 springmvc:war exploded: 部署工件时出错。请参阅服务器日志了解详细信息。
23-Apr-2025 11:19:59.763 信息 [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deploying web application directory [C:\Users\LTSC\Desktop\Tomcat\Tomcat\apache-tomcat-8.5.35\webapps\manager]
23-Apr-2025 11:20:00.186 警告 [localhost-startStop-1] org.apache.catalina.util.SessionIdGeneratorBase.createSecureRandom Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [138] milliseconds.
23-Apr-2025 11:20:00.215 信息 [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web application directory [C:\Users\LTSC\Desktop\Tomcat\Tomcat\apache-tomcat-8.5.35\webapps\manager] has finished in [451] ms

查阅资料:

从你提供的日志中,我们可以看到几个关键的问题:

  1. 32位DLL在64位平台上无法加载:

    复制代码

    复制 插入 新文件

    复制代码
    Can't load IA 32-bit .dll on a AMD 64-bit platform

    这意味着你正在64位的操作系统上运行32位的Tomcat。你需要下载并安装64位的Tomcat版本以匹配你的操作系统。

版本错误,替换tomcat版本后继续操作

相关推荐
yumgpkpm8 分钟前
Acceldata ODP 3.3.6.4 vs CDP Private Cloud Base 7.3.2 对比
大数据·运维·服务器·hadoop·华为·zookeeper·hbase
VX_bysjlw98512 分钟前
数码设备销售网站设计与实现39138-计算机毕设原创(免费领源码+带部署教程)
java·vue.js·spring boot·mysql·tomcat·mybatis·idea
Liuqy-0518 分钟前
特殊进程——孤儿、僵尸、守护进程
linux·运维·服务器
荣码26 分钟前
从0到1搭一个生产级RAG系统:串联前面21篇所有知识
java·python
xuxigifxfh29 分钟前
牛客:HJ170 01序列
java·开发语言·算法·华为机考
野生技术架构师1 小时前
牛客网互联网大厂 Java 高频面试题整理(持续更新)
java·开发语言
等我调个Bug1 小时前
【Linux系统篇】权限
linux·服务器
小师兄吃牛肉1 小时前
Java语法 | 多重循环
java·开发语言·python
Han.miracle1 小时前
MySQL InnoDB:MVCC、记录锁、间隙锁、二级索引MVCC底层原理
java·开发语言
不停喝水2 小时前
【前端转全栈java速通课】 项目实战④7-11节 操作数据库-登录-注册-修改密码-注销-mubatis-plus简化crud-
java·前端·数据库