postgresql|数据库|只读用户的创建和删除(备忘)

bash 复制代码
CREATE USER read_only WITH PASSWORD '密码'
-- 连接到xxx数据库
\c xxx
-- 授予对xxx数据库的只读权限
GRANT CONNECT ON DATABASE xxx TO read_only;
GRANT USAGE ON SCHEMA public TO read_only;
GRANT SELECT ON ALL TABLES IN SCHEMA public TO read_only;
GRANT EXECUTE ON ALL FUNCTIONS IN SCHEMA public TO readonly_user;
ALTER DEFAULT PRIVILEGES IN SCHEMA public GRANT SELECT ON TABLES TO read_only;
ALTER DEFAULT PRIVILEGES FOR USER read_only GRANT SELECT, USAGE ON SEQUENCES TO read_only;
ALTER DEFAULT PRIVILEGES FOR USER read_only GRANT  EXECUTE ON FUNCTIONS TO read_only;

                        


-- 连接到xxxdata数据库
\c xxxdata
-- 授予对xxxdata数据库的只读权限
GRANT CONNECT ON DATABASE xxxdata TO read_only;
GRANT USAGE ON SCHEMA public TO read_only;
GRANT SELECT ON ALL TABLES IN SCHEMA public TO read_only;
ALTER DEFAULT PRIVILEGES IN SCHEMA public GRANT SELECT ON TABLES TO read_only;
GRANT EXECUTE ON ALL FUNCTIONS IN SCHEMA public TO readonly_user;
ALTER DEFAULT PRIVILEGES IN SCHEMA public GRANT SELECT ON TABLES TO read_only;
ALTER DEFAULT PRIVILEGES FOR USER read_only GRANT SELECT, USAGE ON SEQUENCES TO read_only;
ALTER DEFAULT PRIVILEGES FOR USER read_only GRANT  EXECUTE ON FUNCTIONS TO read_only;

说明:GRANT CONNECT ON DATABASE xxx TO read_only; 这里是显式的指定连接哪个数据库,read_only 是用户名称

GRANT SELECT ON ALL TABLES IN SCHEMA public TO read_only; public是默认的模式,如果不是,需要显式的指定哪个模式

ALTER DEFAULT PRIVILEGES IN SCHEMA public GRANT SELECT ON TABLES TO read_only; 是让后续在此模式创建的对象仍然有查询权限

删除read_only 用户

首先,直接删除必定失败,如果目前这个模式下有表的情况下

bash 复制代码
DROP user read_only

报错提示如下:

bash 复制代码
DROP user read_only
> ERROR:  role "read_only" cannot be dropped because some objects depend on it
DETAIL:  privileges for schema public
privileges for database test
privileges for table teachers
privileges for table courses
privileges for default privileges on new relations belonging to role postgres in schema public

根据报错提示逐条解决依赖问题就可以彻底删除此用户了,SQL如下:

bash 复制代码
REVOKE ALL PRIVILEGES on DATABASE test FROM read_only
REVOKE ALL PRIVILEGES on SCHEMA "public" FROM read_only
REVOKE ALL PRIVILEGES ON ALL tables IN SCHEMA "public" FROM read_only
ALTER DEFAULT PRIVILEGES in SCHEMA PUBLIC REVOKE SELECT ON tables FROM read_only

删除用户其实主要就是根据日志来删除,哪留的有关联权限,删除掉就可以了,没什么好说的

相关推荐
IT古董7 小时前
《FDE前沿部署工程师实战教程》33 - Enterprise AI Observability:从Agent Trace到全链路智能运维
数据库·人工智能
for_ever_love__8 小时前
MySQL 主从复制讲透:binlog 原理、搭建步骤与读写分离
java·数据库·mysql·binlog·读写分离·原理·主从复制
Nturmoils12 小时前
GROUP BY 先别想当然,查汇总前把规则跑清楚
数据库
最笨的羊羊12 小时前
Oceanbase数据库系列之:向量数据库核心知识
数据库·oceanbase
fish_xk12 小时前
mysql中的表的约束
数据库·mysql
谢亮_vipxieliang12 小时前
Go Channel 高级模式——从底层原理到扇出扇入实战
java·数据库·golang
ggaofeng14 小时前
自己编写邮件服务器和客户端
数据库
java1234_小锋14 小时前
【技术专题】Mysql8 数据库 - Mysql8 添加,更新,删除数据
数据库·mysql
PaperData14 小时前
2015-2024年各省绿色贸易数据
数据库
小羊没烦恼!14 小时前
系统内部模块(子系统)之间的耦合以及模块(子系统)划分
java·开发语言·前端·数据库·算法·c#