搭建k8s高可用集群,“Unable to register node with API server“

今天,在搭建高可用的k8s集群时 遇到了无法"Unable to register node with API server"
最开始,以为初始化超时是拉取kubeadm相关镜像导致的问题
通过kubeadm config images pull ,预拉取kubeadm依赖的镜像。

root@100 \~# kubeadm config images pull --image-repository registry.aliyuncs.com/google_containers

可以看到,已经成功拉取需要的镜像(这样可以加快kubeadm 初始化的速度)

但是,再次kubeadm init时候,依旧超时。

我又分别去看了 docker、containred的运行状态,都是正常运行的。

当我再次查看 kubelet状态时候,发现

原来,报错原因是没有正确配置 sandbox image

vim /etc/containerd/config.toml #所有节点都需要进行配置

将原先的registry.k8s.io/pause:3.6 替换成 国内的源即可

修改为,重启启动containred

systemctl restart contairned

再次重新初始化k8s集群

root@100 \~# kubeadm init --config kubeadm.yaml --ignore-preflight-errors=SystemVerification

可以看到,已经初始化成功了。

ok, 问题解决 撤!

如转载,请附上原文链接!

相关推荐
虎头金猫2 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS2 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
codeejun3 天前
每日一Go·MySQL-5、锁机制全解析
云原生·golang
赵文宇(温玉)3 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang3 天前
上传本地镜像到harbor中
docker·容器·持续部署
张洛闻Eren3 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
忆~遂愿3 天前
本地片库怎么在外面打开?Plex + cpolar 搭一套可远程访问的私人影音库
docker·容器
Thneonl3 天前
你的 Pod 为什么 Pending:调度器两阶段
后端·kubernetes
不吃香菜kkk、3 天前
CI/CD(GitOps)学习与部署手册
运维·云原生·容器·kubernetes·云计算·jenkins·argocd
ChaITSimpleLove3 天前
云原生性能对决:JDK21虚拟线程+GraalVM vs .NET10/11 技术栈深度对比
微服务·云原生·serverless·graalvm native·native aot·runtime async·.net11/java21