gitops无法连接到Openshift集群

详细报错:

failed to sync cluster https://172.30.0.1:443: failed to load initial state of resource ConsolePlugin.console.openshift.io: conversion webhook for console.openshift.io/v1alpha1, Kind=ConsolePlugin failed: Post "https://webhook.openshift-console-operator.svc:9443/crdconvert?timeout=30s": tls: failed to verify certificate: x509: certificate has expired or is not yet valid: current time 2025-10-27T08:46:54Z is after 2025-10-25T03:59:55Z

解决:

查了各种资料,没有找到任何有用的信息,说来重启试试,结果重启就解决了

bash 复制代码
oc project openshift-console-operator
oc rollout restart deployment/console-operator 
相关推荐
Lsetea6 小时前
OpenSSL verify报unhandled critical extension:error 34与关键扩展排查
运维·https·ssl证书·openssl·证书链
guo_wen_qiang7 小时前
docker的备份与迁移
运维·docker·容器
Ruiery8 小时前
Linux 6.6内核内存管理深度解析(一):物理内存初始化 — memblock 怎么把内存交给 buddy
linux·运维·服务器
2401_868534788 小时前
无线网络规划设计
服务器·网络
库拉镜像AI牛牛8 小时前
短剧内容自动化生产:知漫剧工作室落地教程
大数据·服务器·前端·人工智能·语音识别
Android系统攻城狮8 小时前
Linux Gstreamer深度解析之gst_audio_encoder_get_frame_max调用流程与实战(五十九)
linux·运维·服务器·gstreamer音视频·音视频进阶·gstreamer音视频进阶
l1t9 小时前
DeepSeek总结的一个不含数据的 DuckDB 数据库
服务器·数据库·duckdb
忆挽篱笙歌9 小时前
makefil
linux·运维·服务器
程序员老赵10 小时前
Docker 部署 Dolibarr:轻松搭建开源 ERP/CRM 平台
运维·前端·后端
cws20040110 小时前
监控摄像头选型指南
运维·网络·监控