docker操作记录

gitbook

shell 复制代码
# uname -r 
# yum -y install docker-io
# vi  /etc/docker/daemon.json
修改如下:
{
  "registry-mirrors": ["http://hub-mirror.c.163.com"]
}

# service docker start

启动失败:
报错:Error starting daemon: SELinux is not supported with the overlay2 graph driver on this kernel. Either boot into a newer kernel or disable selinux in docker
查看SELinux状态:
/usr/sbin/sestatus -v ##如果SELinux status参数为enabled即为开启状态
修改/etc/selinux/config 文件 并重启
将SELINUX=enforcing改为SELINUX=disabled

修改默认存储路径
vi /lib/systemd/system/docker.service
添加--data-root=/data/xxxx

mv /var/lib/docker /data/docker 
ln -s /data/docker /var/lib/docker

前端nginx项目打包常用指令:

复制代码
docker命令:
生成镜像(别漏掉最后面的 .):
docker build --rm --tag nginx_webapp:1.0.0 .

查看镜像===》可查看到镜像ID:
docker images

启动 Docker 镜像  对外端口83:
docker run -d -p 83:7777 nginx_webapp:1.0.0 

访问镜像内的 web 服务:
http://192.168.37.129:83/VDU/login.html

执行命令打包镜像:
docker save -o images/nginx_webapp_1.0.0.tar nginx_webapp:1.0.0

------
查看正在运行的容器===》可查看到容器ID:
docker ps

停止某个容器运行
docker stop  容器ID(CONTAINER ID )

删除某个容器:
docker rm   容器ID(CONTAINER ID )

删除某个镜像:
docker rmi 镜像ID(IMAGE ID)

导入镜像
docker load < 农业专班_webapp_2.0.0.tar

#Docker 1.13版本以后,可以使用 docker containers prune 命令,删除孤立的容器。
docker container prune

docker run -ti --rm -v /data/drone/odm_data_aukerman:/datasets/code opendronemap/odm --project-path /datasets

查看都有哪些镜像:docker images

查看都有哪些容器:docker ps -a

进入容器(containerID 是容器的ID):docker exec -it containerID /bin/bash

查看都有哪些目录:ls

Dockerfile文件构建镜像

复制代码
docker build -t imageName .

docker垃圾回收机制

监控docker容器运行状态 shell 脚本

https://blog.csdn.net/zaige66/article/details/94014703?utm_medium=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-2.control\&depth_1-utm_source=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-2.control

docker外部运行程序

复制代码
docker ps -a
docker run -it -v /data/comparison:/opt/comparison comparison /bin/bash
docker start 509db4633889
docker exec -it 509db4633889 /bin/bash

使用nsenter进入Docker容器

https://www.cnblogs.com/xhyan/p/6593075.html

相关推荐
吴声子夜歌6 分钟前
Nginx应用与运维——Nginx负载均衡应用实战(二)
运维·nginx·负载均衡
lisanmengmeng9 分钟前
NRPE 添加命令(一)
linux·运维·服务器
pt104312 分钟前
CML网络仿真入门-2:使用CML模拟网络实验环境
运维·网络协议
沫璃染墨2 小时前
《从零入门Linux系统篇(五十七):线程篇·十——生产者消费者模型进阶:从环形缓冲区到POSIX信号量》
linux·运维·服务器·开发语言·c++·系统架构·信号处理
HAHAXX82 小时前
电商RPA批量上架通用方案:一套流程如何同时跑通拼多多、抖店、淘宝和跨境平台
java·运维·rpa
零基础1232 小时前
LLM Agent 驱动的物模型构建:从设备手册到边缘接入的自动化实践
运维·人工智能·经验分享·python·自动化
更深兼春远3 小时前
第2篇:Dify 部署保姆级教程:用 Docker跑起来
docker·容器·dify
程序猿老A3 小时前
从入门型到企业型:云服务器开放共享型到独享型规格升级
运维·服务器
Ruiery4 小时前
Linux 6.6内核 CPU 深度解析(九):时钟与 TSC — 内核怎么从 PIT/HPET 切到 TSC
linux·运维·服务器
吴声子夜歌5 小时前
Nginx应用与运维——Nginx监控配置及管理(二)
运维·nginx