IE无法正常登录windows2000server的FTP服务器

2008-03-06

一.问题:IE无法正常登录Vsftpd服务器,得要修改IE->选项>高级>使用被动模式(要记得,如果你从I6升到I7重置过IE也应该重新看看它的设置对不对。)

二.责任:应该怎么解决这个问题,做为一个学校网络中心,

学多人连基本的电脑知识都不知道,应该让IE直接登录FTP服务器

三.思考(这一部分,俺没看懂。看得懂的朋友请给我回复):

主动模式下,客户连接 TCP/21,服务器通过 TCP/20 连接客户

被动模式下,客户连接 TCP/21,客户再通过其他端口连接服务器的随机端口卡住的原因,是因为服务器在被动模式下没有打开临时端口让 client 连过来,因此需要几个条件

1、client 没有防火墙时,用主动模式连接即可

2、server 没有防火墙时,用被动模式即可

3、双方都有防火墙时,vsftpd 设置被动模式高端口范围,server 打开那段范围,client 用被动模式连接即可

4、加载 ip_conntrack_ftp 模块,使 server 支持 connection tracking,支持临时打洞,client 用被动模式即可

5、server 使用 ip_conntrack_ftp、client 使用 ip_conntrack_ftp 和 ip_nat_ftp,支持临时打洞和临时 NAT 穿越打洞,双方使用主动或被动模式均可四.解决

1.在vsftpd主配置文件/etc/vsftpd/vsftpd.conf里添加

pasv_enable=yes

pasv_min_port=50000

pasv_max_port=60000

重启vs.2.开放防火墙中的端口号,需修改防火墙配置文件/etc/sysconfig/iptables,需打开以下端口。

-A RH-Firewall-1-INPUT -p tcp --dport 50000:60000 - j ACCEPT

-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 21 -j ACCEPT

重启iptables.OK!

相关推荐
比兔代理27 分钟前
正向代理与反向代理技术辨析,为什么代理 IP 属于正向代理
服务器·网络·http·ip
Wang's Blog2 小时前
Java 接入Redis: 通用命令与键管理
java·服务器·redis
Wang's Blog2 小时前
Java 接入Redis: 列表集合与有序集合操作命令
java·服务器·redis
蓝速科技2 小时前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
Ivanqhz2 小时前
SVD++算法
java·服务器·网络·深度学习·神经网络
chicheese3 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky3 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南4 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
我命由我123454 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人4 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器