829. 模拟队列,手写队列

实现一个队列,队列初始为空,支持四种操作:

  1. push x -- 向队尾插入一个数 x;
  2. pop -- 从队头弹出一个数;
  3. empty -- 判断队列是否为空;
  4. query -- 查询队头元素。

现在要对队列进行 M 个操作,其中的每个操作 33 和操作 44 都要输出相应的结果。

输入格式

第一行包含整数 M,表示操作次数。

接下来 M 行,每行包含一个操作命令,操作命令为 push xpopemptyquery 中的一种。

输出格式

对于每个 emptyquery 操作都要输出一个查询结果,每个结果占一行。

其中,empty 操作的查询结果为 YESNOquery 操作的查询结果为一个整数,表示队头元素的值。

数据范围

1≤M≤100000,

1≤x≤109

所有操作保证合法。

输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4

代码 :

cpp 复制代码
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<math.h>
#include<map>
#include<unordered_map>
using namespace std;
typedef long long LL;
const int N = 1e5 + 5;
int n;
int q[N],hh,tt=-1;

int main(){
    cin>>n;
    char op[20];
    int x;
    while(n--){
        scanf("%s",op);
        if(!strcmp(op,"push")){
            scanf("%d",&x);
            q[++tt]=x;
        }
        else if(!strcmp(op,"empty")){
            if(hh<=tt)printf("NO\n");
            else printf("YES\n");
        }
        else if(!strcmp(op,"query")){
            printf("%d\n",q[hh]);
        }
        else if(!strcmp(op,"pop")){
            if(hh<=tt)
            hh++;
        }
    }
    return 0;
}
相关推荐
搬砖的小码农_Sky2 小时前
C语言:数组
c语言·数据结构
Swift社区2 小时前
LeetCode - #139 单词拆分
算法·leetcode·职场和发展
Kent_J_Truman3 小时前
greater<>() 、less<>()及运算符 < 重载在排序和堆中的使用
算法
先鱼鲨生3 小时前
数据结构——栈、队列
数据结构
一念之坤3 小时前
零基础学Python之数据结构 -- 01篇
数据结构·python
IT 青年4 小时前
数据结构 (1)基本概念和术语
数据结构·算法
熬夜学编程的小王4 小时前
【初阶数据结构篇】双向链表的实现(赋源码)
数据结构·c++·链表·双向链表
Dong雨4 小时前
力扣hot100-->栈/单调栈
算法·leetcode·职场和发展
SoraLuna4 小时前
「Mac玩转仓颉内测版24」基础篇4 - 浮点类型详解
开发语言·算法·macos·cangjie
liujjjiyun4 小时前
小R的随机播放顺序
数据结构·c++·算法