开发板启动进入系统以后再挂载 NFS 文件系统, 这里的NFS文件系统是根据正点原子教程制作的ubuntu_rootfs

  1. 如果是想开发板启动进入系统以后再挂载 NFS 文件系统,开发板启动进入文件系统,开发板和 ubuntu 能互相 ping 通,在开发板文件系统下新建一个目录 you,然后执行如下指令进行挂载:
    mkdir mi
    mount -t nfs -o nolock,nfsvers=3 192.168.0.188:/home/MY/NFS/myrootfs mi/
    ls mi/查看挂载的nfs文件系统内容.

注意目前的工作目录还没切换到nfs文件系统,需要执行下面三个步骤:

  1. 在根目录下创建mount.sh:

echo "MOUNTING"

mount -t proc /proc /mi/proc

mount -t sysfs /sys /mi/sys

mount -o bind /dev /mi/dev

mount -o bind /dev/pts /mi/dev/pts

chroot /mi

  1. 在根目录下创建mount.sh:
    echo "UNMOUNTING"
    umount /mi/proc
    umount /mi/sys
    umount /mi/dev/pts
    umount /mi/dev
  2. cd进入mi,执行mount.sh即可切换到nfs文件系统
  3. 执行sudo fdisk -l,可见执行sudo命令说明已经成功到ubuntu_rootfs 了
    6.执行exit后再执行unmount.sh即可退后到开发板原有的文件系统,这是sudo命令已经无法执行。说明退回成功。

后记:

我这里是把电脑ethernet网卡和开发板的eth0直连的。电脑设定一个固定ip 192.168.0.11(要把wifi禁止掉). ubuntu虚拟机的ip设置为192.168.0.188.开发板的ip设定为固定的ip 192.168.0.50.

电脑ip:

开发板ip:

ubuntu虚拟机ip:

后记2:

通过mfgtool把文件系统下载到emmc后也可以启动了。

但是要保证使用sudo tar -vcjf ubuntu_rootfs.tar.bz2 * 打包时没有报一些文件权限不足。

如果tar的时候提示下面错误,会造成从emmc启动会,root密码一直错误无法登入到系统中。

后记3

如果在一个终端把root目前中切换到创建的ubuntu目录中,在另外一个终端无法tar打包。

sudo tar -vcjf ubuntu_rootfs.tar.bz2 * 在另外一个终端会报错,并且卡在proc/kcore里面

tar -vcjf ubuntu_rootfs.tar.bz2 * 不带sudo可以打包,但是会报大量的无法open错误。并且会报 tar: 由于前次错误,将以上次的错误状态退出

相关推荐
未济2 天前
linux 配置环境变量
linux
傲世仙尊2 天前
目录即文件-Ext文件系统收尾篇
linux·c语言
_艾伦 耶格尔.2 天前
进程间通信
linux
深圳老胡2 天前
STM32F407 控制 L6470 步进电机驱动 —— 控制过程简介
笔记·stm32·单片机·嵌入式硬件·代码规范
Liuqy-052 天前
Linux IO编程——静态库、动态库
linux
女神下凡2 天前
嵌入式设计的各种存储芯片的硬件/软件设计规范,非常全面。
arm开发·单片机·嵌入式硬件
彧azz2 天前
Linux 环境下 Redis 学习总结:数据类型、持久化、锁、事务、主从与缓存问题
linux·redis·笔记·学习·面试
-梅2 天前
linux(8) 软硬链接
linux·运维·服务器
AIgorithmGEEK2 天前
[Linux]线程三部曲(上):一个执行流的诞生——从操作系统一路拆到 pthread_create
linux·线程·pid
琥珀色糖2 天前
SimlpeHttp
linux·服务器