开发板启动进入系统以后再挂载 NFS 文件系统, 这里的NFS文件系统是根据正点原子教程制作的ubuntu_rootfs

  1. 如果是想开发板启动进入系统以后再挂载 NFS 文件系统,开发板启动进入文件系统,开发板和 ubuntu 能互相 ping 通,在开发板文件系统下新建一个目录 you,然后执行如下指令进行挂载:
    mkdir mi
    mount -t nfs -o nolock,nfsvers=3 192.168.0.188:/home/MY/NFS/myrootfs mi/
    ls mi/查看挂载的nfs文件系统内容.

注意目前的工作目录还没切换到nfs文件系统,需要执行下面三个步骤:

  1. 在根目录下创建mount.sh:

echo "MOUNTING"

mount -t proc /proc /mi/proc

mount -t sysfs /sys /mi/sys

mount -o bind /dev /mi/dev

mount -o bind /dev/pts /mi/dev/pts

chroot /mi

  1. 在根目录下创建mount.sh:
    echo "UNMOUNTING"
    umount /mi/proc
    umount /mi/sys
    umount /mi/dev/pts
    umount /mi/dev
  2. cd进入mi,执行mount.sh即可切换到nfs文件系统
  3. 执行sudo fdisk -l,可见执行sudo命令说明已经成功到ubuntu_rootfs 了
    6.执行exit后再执行unmount.sh即可退后到开发板原有的文件系统,这是sudo命令已经无法执行。说明退回成功。

后记:

我这里是把电脑ethernet网卡和开发板的eth0直连的。电脑设定一个固定ip 192.168.0.11(要把wifi禁止掉). ubuntu虚拟机的ip设置为192.168.0.188.开发板的ip设定为固定的ip 192.168.0.50.

电脑ip:

开发板ip:

ubuntu虚拟机ip:

后记2:

通过mfgtool把文件系统下载到emmc后也可以启动了。

但是要保证使用sudo tar -vcjf ubuntu_rootfs.tar.bz2 * 打包时没有报一些文件权限不足。

如果tar的时候提示下面错误,会造成从emmc启动会,root密码一直错误无法登入到系统中。

后记3

如果在一个终端把root目前中切换到创建的ubuntu目录中,在另外一个终端无法tar打包。

sudo tar -vcjf ubuntu_rootfs.tar.bz2 * 在另外一个终端会报错,并且卡在proc/kcore里面

tar -vcjf ubuntu_rootfs.tar.bz2 * 不带sudo可以打包,但是会报大量的无法open错误。并且会报 tar: 由于前次错误,将以上次的错误状态退出

相关推荐
大猫会长4 小时前
调用codebuddy集成的supabase授权白屏解决方法
linux·运维·服务器
羔羊++4 小时前
29_实验二十八_buildroot配置与编译
linux
LoneEon4 小时前
CentOS7 部署 Nacos3.x 集群实战:从注册中心到 AI 管理中心
linux·人工智能·nacos
传人5 小时前
为什么 Xshell 中可以通过java -version查询到java 版本号码,Electerm 却查不到?
java·linux·服务器
fly_sunnn5 小时前
STM32-GPIO输出以及按键控制LED&光敏传感器控制蜂鸣器
stm32·单片机·嵌入式硬件
鬼手点金5 小时前
opencode-全能开发者配置
java·linux·服务器·前端·javascript·学习·前向传播
数字新视界5 小时前
U位资产管理系统发布全面数字化监控解决方案
嵌入式硬件·物联网·系统架构·机房管理·动力与环境监控系统
xixiaoyunya6 小时前
虚拟机备份怎么做:镜像级与文件级搭配的完整实操方案
linux·运维·网络
墨家句子6 小时前
服务器被反复尝试登录之后:fail2ban 加密钥登录的五道加固
linux·后端
阿明66 小时前
进程替换【Linux】
linux·运维·服务器