Redis主从架构中从节点的master_link_status:down

项目场景:

在搭建Redis的主从架构时,查看Redis的从节点状态时发现其连接的主节点的状态为down,并且查看主节点的状态时发现连接的从节点数量为0。


问题描述


原因分析:

可能在主节点中配置了密码,即requirepass。


解决方案:

将从节点和主节点的requirepass密码配置相同,然后将从节点 的配置文件中的masterauth属性进行填写,密码就是主从节点的密码。

最重要的是完成上述配置后将linux中的redis集群节点的进程全部杀掉,重新启动集群的redis节点并配置主从关系,才能解决上述bug!

相关推荐
hweiyu0012 小时前
Redis命令:HSTRLEN
redis·缓存
阳光九叶草LXGZXJ12 小时前
达梦数据库-报错-15-列【XXX】长度超出定义
linux·运维·数据库·sql·学习
奔跑的大白啊13 小时前
多容器共享目录权限踩坑记
linux·ubuntu·共享目录·linux权限·docker 容器化部署
字节渡客13 小时前
Redis键明明过期了,业务还在读到旧数据
数据库·redis·spring
Devlive 开源社区13 小时前
AuthX 正式更名 GrantForge:我们重新做了一遍权限管理系统
大数据·人工智能·架构
To_OC14 小时前
从一头雾水到跑通全流程:我用一个周末啃透了JWT登录鉴权
前端·后端·http
微三云生态系统架构师-彭丹15 小时前
抖店OPC智能选品与铺货架构:多店差异化与频率风控设计
架构
前端兰博15 小时前
05-Redis
redis·后端
集智飞行15 小时前
无人机集群通信架构剖析,以及对未来发展的几点判断
架构·无人机
想要打 Acm 的小周同学呀15 小时前
无需自己设计Agent架构的业务系统,依赖第三方Agent,基于SKILL和MCP服务实现企业级内部提效工具开发
架构·agent