宝塔面板SRS音视频TRC服务器启动失败

首先,查找原因

1.先看srs服务在哪

Linux 复制代码
find / -type f -name srs 2>/dev/null

运行结果:

Linux 复制代码
/var/lib/docker/overlay2/5347867cc0ffed43f1ae24eba609637bfa3cc7cf5f8c660976d2286fa6a88d2b/diff/usr/local/srs/objs/srs
/var/lib/docker/overlay2/5347867cc0ffed43f1ae24eba609637bfa3cc7cf5f8c660976d2286fa6a88d2b/diff/usr/local/srs/etc/init.d/srs
/var/lib/docker/overlay2/1055a7db13201f6d360446bb7e82cd1af5149547b96d906430ac5780bfb12b8b/diff/usr/local/srs/objs/srs
/var/lib/docker/overlay2/1055a7db13201f6d360446bb7e82cd1af5149547b96d906430ac5780bfb12b8b/diff/usr/local/srs/etc/init.d/srs

2.查看所有docker应用

Linux 复制代码
docker ps -a

运行结果:

Linux 复制代码
CONTAINER ID   IMAGE                                                        COMMAND                  CREATED         STATUS                     PORTS     NAMES
f26ee488e3d4   registry.cn-hangzhou.aliyuncs.com/ossrs/srs-stack:v5.12.17   "./bootstrap"            7 minutes ago   Created                              srs-stack
fc4fa444888d   tiangolo/nginx-rtmp                                          "nginx -g 'daemon of..."   2 hours ago     Exited (0) 7 minutes ago             dk_rtmp-nginx-rtmp-1

找打了name为srs-stack的应用

3.在docker里面运行srs

Linux 复制代码
docker start srs-stack

运行结果:

Linux 复制代码
Error response from daemon: driver failed programming external connectivity on endpoint srs-stack (e14ce5129c6c3068f14bbbb406cb3688bc8232238e3dc290d3650ad114b69252): Error starting userland proxy: listen tcp4 0.0.0.0:8080: bind: address already in use
Error: failed to start containers: srs-stack片

找到原因了,端口8080被占用

4.修改修改占用端口,我的是frp的 vhost_http_port=8080占用了,我将它注释掉

bash 复制代码
# vhost_http_port=8080

每个人根据自己的服务进程修改掉占用端口的程序即可

再次启动

bash 复制代码
docker start srs-stack

报错:

bash 复制代码
Error response from daemon: driver failed programming external connectivity on endpoint srs-stack (2f9ade46a5f6d4b971622986c8304b34488c0a5440082a190a190f1a4467cba9): Bind for 0.0.0.0:1935 failed: port is already allocated

5.修改配置文件docker-compose.yml,首先查找该文件

Linux 复制代码
find / -name docker-compose.yml 2>/dev/null

运行结果:

Linux 复制代码
/www/dk_project/dk_app/dk_rtmp/docker-compose.yml

用ftp工具下载该配置文件,打开,内容如下:

bash 复制代码
version: '3'
services:
  nginx-rtmp:
    image: tiangolo/nginx-rtmp
    ports:
      - ${RTMP_PORT}:1935
    volumes:
      - ./data:/data
    restart: unless-stopped

将1935改成1936

6.修改.env文件

在相同目录下可以找到,同样的,下载打开

bash 复制代码
RTMP_PORT=1935
RTMP_PATH=/www/dk_project/dk_app/dk_rtmp

将1935改成1936

7.执行修改

bash 复制代码
cd /www/dk_project/dk_app/dk_rtmp
docker-compose down
docker-compose up -d

8.再次运行srs-stack

bash 复制代码
docker start srs-stack

没有报错,结果如下:

bash 复制代码
[root@VM-0-14-tencentos dk_rtmp]# docker start srs-stack
srs-stack

再去启动看看,启动成功!

进入后台管理面板,成功~

相关推荐
音视频牛哥2 小时前
四足机器人如何做好智慧电力巡检?从低延迟图传到可信巡检数据闭环
音视频·四足机器人·智慧电力巡检·whip whep·机器人巡检·工业音视频巡检·智能电力巡检技术方案
YoungStudyAI3 小时前
QA的下一个自动化阶段,可能不是再写更多脚本,而是设计测试Agent
运维·自动化
筝筝ba3 小时前
openBMC功耗封顶GUI测试
服务器
分布式存储与RustFS4 小时前
纠删码到底吃掉了多少容量:EC:4、EC:8 的利用率与容错怎么算
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
美狐美颜sdk4 小时前
直播APP接入美颜SDK后出现卡顿怎么办?从性能瓶颈寻找解决方案
android·人工智能·音视频·美颜sdk·直播美颜sdk
遇见小修修4 小时前
3步解决打印机0x00000709报错 ,广州深圳程序员可自行排查
运维·打印机·维修·打印机报错·打印机运维·打印机故障自查
美狐美颜SDK开放平台4 小时前
直播APP开发实战:从摄像头调用到视频美颜sdk集成
android·人工智能·计算机视觉·音视频·直播美颜sdk
niuTaylor4 小时前
飞腾 FT-2000/4 Ubuntu 内存卡 / NVMe SSD 系统制作完整指南
linux·服务器·人工智能·驱动开发·单片机
Huangjin007_6 小时前
【Linux 系统篇(二十五)】文件(二) 系统文件I/O详解
linux·运维·服务器
2601_962381136 小时前
历史视频朝代更替动效怎么做?把 AE 关键帧换成 AI 分镜动画的实战拆解
人工智能·nginx·音视频