Acwing154滑动窗口

题目

给定一个大小为 n≤10^6 的数组。

有一个大小为 k 的滑动窗口,它从数组的最左边移动到最右边。

你只能在窗口中看到 k 个数字。

每次滑动窗口向右移动一个位置。

以下是一个例子:

该数组为 [1 3 -1 -3 5 3 6 7],k 为 33。

窗口位置 最小值 最大值
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7

你的任务是确定滑动窗口位于每个位置时,窗口中的最大值和最小值。

输入格式

输入包含两行。

第一行包含两个整数 n 和 k,分别代表数组长度和滑动窗口的长度。

第二行有 n 个整数,代表数组的具体数值。

同行数据之间用空格隔开。

输出格式

输出包含两个。

第一行输出,从左至右,每个位置滑动窗口中的最小值。

第二行输出,从左至右,每个位置滑动窗口中的最大值。

输入样例:

复制代码
8 3
1 3 -1 -3 5 3 6 7

输出样例:

diff 复制代码
-1 -3 -3 -3 3 3
3 3 5 5 6 7

代码与思路

java 复制代码
import java.io.*;

public class Main {
    static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));  // 用于读取输入数据的缓冲读取器
    static BufferedWriter log = new BufferedWriter(new OutputStreamWriter(System.out));  // 用于输出结果的缓冲写入器

    public static void main(String[] args) throws IOException {
        // 对输入数据进行初始化
        String[] s1 = reader.readLine().split(" ");
        int n = Integer.parseInt(s1[0]);  // 数组长度
        int k = Integer.parseInt(s1[1]);  // 滑动窗口大小
        String[] s = reader.readLine().split(" ");
        int[] a = new int[n];  // 输入数组
        for (int i = 0; i < n; i++) {
            a[i] = Integer.parseInt(s[i]);  // 初始化输入数组
        }
        int[] ans = new int[n];  // 存储滑动窗口中的最小(或最大)值的下标
        int tt = -1, hh = 0;  // 初始化队列的头尾指针

        // 查找滑动窗口中的最小值
        for (int i = 0; i < n; i++) {
            if (hh <= tt && i - k + 1 > ans[hh]) {
                hh++;
            }
            while (hh <= tt && a[i] <= a[ans[tt]]) {
                tt--;
            }
            ans[++tt] = i;
            if (i + 1 >= k) {
                log.write(a[ans[hh]] + " ");  // 输出滑动窗口中的最小值
            }
        }

        log.write("\n");  // 换行

        tt = -1;  // 重新初始化队列的尾指针
        hh = 0;  // 重新初始化队列的头指针
        // 查找滑动窗口中的最大值
        for (int i = 0; i < n; i++) {
            if (hh <= tt && i - k + 1 > ans[hh]) {
                hh++;
            }
            while (hh <= tt && a[i] >= a[ans[tt]]) {
                tt--;
            }
            ans[++tt] = i;
            if (i + 1 >= k) {
                log.write(a[ans[hh]] + " ");  // 输出滑动窗口中的最大值
            }
        }

        // 关闭输入输出流
        log.flush();
        reader.close();
        log.close();
    }
}
相关推荐
跟着珅聪学java28 分钟前
spring boot +Elment UI 上传文件教程
java·spring boot·后端·ui·elementui·vue
徐小黑ACG1 小时前
GO语言 使用protobuf
开发语言·后端·golang·protobuf
战族狼魂4 小时前
CSGO 皮肤交易平台后端 (Spring Boot) 代码结构与示例
java·spring boot·后端
杉之6 小时前
常见前端GET请求以及对应的Spring后端接收接口写法
java·前端·后端·spring·vue
hycccccch6 小时前
Canal+RabbitMQ实现MySQL数据增量同步
java·数据库·后端·rabbitmq
bobz9657 小时前
k8s 怎么提供虚拟机更好
后端
bobz9657 小时前
nova compute 如何创建 ovs 端口
后端
用键盘当武器的秋刀鱼7 小时前
springBoot统一响应类型3.5.1版本
java·spring boot·后端
Asthenia04128 小时前
从迷宫到公式:为 NFA 构造正规式
后端
Asthenia04128 小时前
像整理玩具一样:DFA 化简和状态等价性
后端