K8S容器挂了后一直重启但不成功原因及解决

K8S容器挂了后一直重启但不成功原因及解决

背景:

应用迁移K8S后,因为POD OOM挂了后,会进行重启,但一直在重启,重启多次都不成功,且应用无报错日志。其他K8S上应用挂了后会自动重启成功。

原因:

健康检查配置的livenessProbe和readinessProbe配置的initialDelaySeconds太小,应用启动成功所需时间比配置的长,导致POD重启了initialDelaySeconds时间后,探针健康检查失败,则进行新一轮的重启。

解决:

根据应用实际启动完成时间,调整livenessProbe和readinessProbe配置的initialDelaySeconds。

相关推荐
九皇叔叔22 分钟前
Kubernetes 资源管理方式详解:命令式与声明式管理
docker·容器·k8s
蓝速科技35 分钟前
会议室门牌公告通知发布选型与落地指南丨蓝速科技
大数据·运维·数据库·人工智能·科技
chicheese1 小时前
Linux 面试速查表:从初级到高级,附高频场景答题模板
linux·运维
Linux-lucky2 小时前
32-38-Linux学习之旅之MySQL综合
linux·运维·学习·mysql·ubuntu
智能运维指南2 小时前
2026年ITSM系统怎么选?四款主流方案与五维评估模型
运维·itsm·嘉为蓝鲸
vortex52 小时前
常用终端模拟器全面对比:Kitty、WezTerm、Ghostty 与 Konsole
linux
我命由我123453 小时前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人3 小时前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender3 小时前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
INGNIGHT4 小时前
270 · 电话号码的字母组合II(Trie)
linux·算法