文章目录
一、题目描述
【深基3.习8】三角形分类
题目描述
给出三条线段 a , b , c a,b,c a,b,c 的长度,均是不大于 10000 10000 10000 的正整数。打算把这三条线段拼成一个三角形,它可以是什么三角形呢?
- 如果三条线段不能组成一个三角形,输出
Not triangle
; - 如果是直角三角形,输出
Right triangle
; - 如果是锐角三角形,输出
Acute triangle
; - 如果是钝角三角形,输出
Obtuse triangle
; - 如果是等腰三角形,输出
Isosceles triangle
; - 如果是等边三角形,输出
Equilateral triangle
。
如果这个三角形符合以上多个条件,请按以上顺序分别输出,并用换行符隔开。
输入格式
输入 3 个整数 a a a、 b b b 和 c c c。
输出格式
输出若干行判定字符串。
样例 #1
样例输入 #1
3 3 3
样例输出 #1
Acute triangle
Isosceles triangle
Equilateral triangle
样例 #2
样例输入 #2
3 4 5
样例输出 #2
Right triangle
样例 #3
样例输入 #3
6 10 6
样例输出 #3
Obtuse triangle
Isosceles triangle
样例 #4
样例输入 #4
1 14 5
样例输出 #4
Not triangle
提示
当两短边的平方和大于一长边的平方,说明是锐角三角形。
当两短边的平方和等于一长边的平方,说明是直角三角形。
当两短边的平方和小于一长边的平方,说明是钝角三角形。
二、参考代码
cpp
#include <iostream>
#include <math.h>
#include <algorithm>
using namespace std;
void bubbleSort(int arr[], int n) {
for (int i = 0; i < n - 1; i++) {
for (int j = 0; j < n - i - 1; j++) {
if (arr[j] > arr[j + 1]) {
// 交换元素
int temp = arr[j];
arr[j] = arr[j + 1];
arr[j + 1] = temp;
}
}
}
}
int main(void)
{
int a[3] = { 0 };
for (int i = 0; i < 3; i++)
{
cin >> a[i];
}
bubbleSort(a, 3);
if (a[0] + a[1] <= a[2])
{
cout << "Not triangle" << endl;
}
else
{
if (a[0] * a[0] + a[1] * a[1] == a[2] * a[2])
{
cout << "Right triangle" << endl;
}
else if (a[0] * a[0] + a[1] * a[1] > a[2] * a[2])
{
cout << "Acute triangle" << endl;
}
else if(a[0] * a[0] + a[1] * a[1] < a[2] * a[2])
{
cout << "Obtuse triangle" << endl;
}
if(a[0] == a[1])
{
cout << "Isosceles triangle" <<endl;
if (a[0] == a[2])
{
cout << "Equilateral triangle" << endl;
}
}
}
}