阿里云服务器(Ubuntu22)上的MySQL8数据库下载,安装和远程连接

最近阿里云centos主机到期了改为使用Ubuntu操作系统,在上面安装mysql并远程连接出现了一系列问题并解决。

之前在centos系统上下载mysql8的教程如下:
阿里云服务器(centos7)上的MySQL8数据库下载,安装和远程连接

主机操作系统类型:

1.安装

bash 复制代码
#更新
apt-get update

#安装mysqlserver
apt-get install mysql-server

#使得mysql可以远程登陆
vim /etc/mysql/mysql.conf.d/mysqld.cnf
#注释掉这一行
#bind-address = 127.0.0.1

#重启mysql
service mysql restart;

2.修改root密码和能够远程连接

bash 复制代码
ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'P@ssw0rd'; 

mysql -u root -p (mysql8只能用两句执行了)  
CREATE USER 'root'@'%' IDENTIFIED BY 'P@ssw0rd';  
GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION;

3.问题

ERROR 1698 (28000): Access denied for user 'root'@'localhost'。

原因:MySQL默认使用了UNIX auth_socket plugin插件。简单来说这意味着当db_users使用数据库时,将会通过系统用户认证表进行认证。你可以通过下面的命令看看你的root用户是否设置成了这样:

就像你在查询语句中看到的那样,root用户在使用auth_socket插件。

设置你的root用户使用mysql_native_password插件 。

bash 复制代码
UPDATE user SET plugin='mysql_native_password' WHERE User='root';

但是这样会导致root需要重新设置密码;

bash 复制代码
ALTER USER 'root'@'%' IDENTIFIED WITH mysql_native_password BY 'P@ssw0rd'; 
相关推荐
IvorySQL2 小时前
PostgreSQL 日报|修复截断 zstd 备份检测(10 月 9 日)
数据库·postgresql
AliCloudROS2 小时前
计算巢 X DeepSeek Harness — 云端智能体工作台
人工智能·阿里云
刘胡子大叔2 小时前
SQL 脚本的导入顺序
数据库·sql
天启HTTP2 小时前
爬虫防封核心原理:IP轮换机制与风控规避逻辑
linux·服务器·网络·爬虫·tcp/ip
代码什么用2 小时前
Spring对IoC的实现
数据库·spring
运维行者_3 小时前
网络性能监控怎么做?从自动发现到根因分析的4个环节
运维·服务器·网络·人工智能·支持向量机
hz567895 小时前
涉密视频会议设备配置指南:终端、音视频采集与配套设施选型
服务器·网络·数据库·安全·实时音视频·信息与通信·智能硬件
广州浮点FLOATLIC5 小时前
许可证服务器迁移后软件打不开:研发 IT 怎样定位连接问题
linux·服务器·数据库
程序员Sunday5 小时前
MySQL 为什么使用 B+ 树索引?把范围查询、回表和覆盖索引连起来
数据库·mysql
优橙教育5 小时前
零基础学AI应用开发要多久?3个月能到什么水平
服务器·开发语言·网络·php