PostgreSQL启动报错“could not map anonymous shared memory: Cannot allocate memory”

PostgreSQL启动报错"could not map anonymous shared memory: Cannot allocate memory"

bash 复制代码
基础信息
OS版本:Red Hat Enterprise Linux Server release 7.9 (Maipo)
DB版本:16.2
pg软件目录:/home/pg16/soft
pg数据目录:/home/pg16/data
端口:5777

报错

bash 复制代码
[pg16@test ~]$ pg_ctl start
waiting for server to start....2024-06-01 22:20:02.156 PDT [68668] DEBUG:  registering background worker "logical replication launcher"
2024-06-01 22:20:02.157 PDT [68668] DEBUG:  loaded library "pg_stat_statements"
2024-06-01 22:20:02.157 PDT [68668] FATAL:  could not map anonymous shared memory: Cannot allocate memory
2024-06-01 22:20:02.157 PDT [68668] HINT:  This error usually means that PostgreSQL's request for a shared memory segment exceeded available memory, swap space, or huge pages. To reduce the request size (currently 295698432 bytes), reduce PostgreSQL's shared memory usage, perhaps by reducing shared_buffers or max_connections.
2024-06-01 22:20:02.157 PDT [68668] LOG:  database system is shut down
 stopped waiting
pg_ctl: could not start server
Examine the log output.

PostgreSQL 请求的共享内存段超出了当前可用的内存、交换空间或大页内存 (huge pages)。当前请求的内存大小为 295,698,432 字节(约 282 MB)。

分析记录

bash 复制代码
[pg16@test ~]$ cat data/postgresql.conf |grep shared
shared_buffers = 256MB                  # min 128kB
#shared_memory_type = mmap              # the default is the first option
dynamic_shared_memory_type = posix      # the default is usually the first option
#min_dynamic_shared_memory = 0MB        # (change requires restart)
#wal_buffers = -1                       # min 32kB, -1 sets based on shared_buffers
shared_preload_libraries = 'pg_stat_kcache,pg_stat_statements,auto_explain'     # (change requires restart)
[pg16@test ~]$ cat /proc/meminfo |grep Huge
AnonHugePages:    942080 kB
HugePages_Total:     150
HugePages_Free:        7
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB

发现空闲的大页只有7个,不满足pg的启动需求,故报错。最终发现是其它数据库进程占用了,停了之后pg可以正常启动。

解决

bash 复制代码
[pg16@test log]$ pg_ctl start
waiting for server to start....2024-06-02 06:43:45.043 PDT [3636] DEBUG:  registering background worker "logical replication launcher"
2024-06-02 06:43:45.043 PDT [3636] DEBUG:  loaded library "pg_stat_statements"
2024-06-02 06:43:45.051 PDT [3636] LOG:  redirecting log output to logging collector process
2024-06-02 06:43:45.051 PDT [3636] HINT:  Future log output will appear in directory "log".
 done
server started

谨记:心存敬畏,行有所止。

相关推荐
mi200614 小时前
不合规MAC地址导致通信故障
运维
sbjdhjd14 小时前
云安全 | 从特权容器到旧版 runC:Docker 宿主机访问与运行时缺陷复盘
运维·网络安全·docker·云原生·kubernetes·云计算·云安全
Hello_Pyhx14 小时前
Ventoy:Linux制盘与排障
linux·运维·服务器
pt104314 小时前
从阿波罗13号到命令行的网络实验转向
运维·网络
行业研究员15 小时前
Agent Memory降低Token消耗原理解析
数据库·人工智能·oracle·腾讯云·智能体
yixun_gdas15 小时前
企业网站内容巡查的价值与方法:企业官网的合规与形象管理
数据库·内容运营
见闻小天地15 小时前
空调机房赛莱默B&G冷冻泵/冷却泵的核心技术特性分析
大数据·运维·数据库
辛迪聊物业数字化15 小时前
物业管理系统新手部署与实操指南
数据库·物联网·架构·系统架构
microxiaoxiao15 小时前
MobaXterm vs Aeroshell
linux·运维·ssh
March.s15 小时前
MySQL 数据库原理与实战:从数据管理到 LAMP 建站全解
数据库·mysql