RabbitMQ启动报错:Error during startup: {error, {schema_integrity_check_failed,

报错信息如下:

复制代码
Error during startup: {error,
                          {schema_integrity_check_failed,
                              [{table_attributes_mismatch,rabbit_user,
                                   [username,password_hash,tags,
                                    hashing_algorithm,limits],
                                   [username,password_hash,tags,
                                    hashing_algorithm]},
                               {table_attributes_mismatch,rabbit_vhost,
                                   [virtual_host,limits,metadata],
                                   [virtual_host,limits]},
                               {table_attributes_mismatch,
                                   rabbit_durable_queue,
                                   [name,durable,auto_delete,exclusive_owner,
                                    arguments,pid,slave_pids,sync_slave_pids,
                                    recoverable_slaves,policy,operator_policy,
                                    gm_pids,decorators,state,policy_version,
                                    slave_pids_pending_shutdown,vhost,options,
                                    type,type_state],
                                   [name,durable,auto_delete,exclusive_owner,
                                    arguments,pid,slave_pids,sync_slave_pids,
                                    recoverable_slaves,policy,operator_policy,
                                    gm_pids,decorators,state,policy_version,
                                    slave_pids_pending_shutdown,vhost,
                                    options]},
                               {table_attributes_mismatch,rabbit_queue,
                                   [name,durable,auto_delete,exclusive_owner,
                                    arguments,pid,slave_pids,sync_slave_pids,
                                    recoverable_slaves,policy,operator_policy,
                                    gm_pids,decorators,state,policy_version,
                                    slave_pids_pending_shutdown,vhost,options,
                                    type,type_state],
                                   [name,durable,auto_delete,exclusive_owner,
                                    arguments,pid,slave_pids,sync_slave_pids,
                                    recoverable_slaves,policy,operator_policy,
                                    gm_pids,decorators,state,policy_version,
                                    slave_pids_pending_shutdown,vhost,
                                    options]},
                               {table_missing,rabbit_index_route},
                               {table_missing,
                                   rabbit_node_maintenance_states}]}}

我查阅资料大概有三种可能:

1、你的rabbitMQ的版本信息和erlang的版本信息对应不上

2、你的安装路径中存在中文或空格

3、还有一种,删除一下路径中的文件,然后重新启动rabbitMQ就可以了,我的就属于第三种:

但是暂时我也不太清楚要删除这个文件,如果有知道的朋友可以再评论区留言,我们共同学习~

相关推荐
迪康Defender6 分钟前
终端安全实践:浅谈端点安全管理系统内置终端防火墙能力
运维·服务器·网络·经验分享·安全·php·终端安全管理
AI备忘录9 分钟前
(二十二)华为华三锐捷迈普思科 802.1X 端口认证配置命令(网络准入五厂商对照)
运维·服务器·开发语言·网络·安全·华为
倔强的小石头_16 分钟前
Ubuntu部署Prometheus与Alertmanager:systemd配置、告警对接及cpolar远程访问
数据库·ubuntu·prometheus
茉莉玫瑰花茶18 分钟前
GO [ 接口 ]
服务器·数据库·golang
babe小鑫22 分钟前
金融工程专业秋招:金融类证书与数据分析类证书的搭配方案
大数据·数据库·人工智能
夜雪一千26 分钟前
Python URL解码详解:单层、双重URL解码实战与踩坑指南
linux·服务器·python
程序员_小兵26 分钟前
PCIe Switch Fabric 技术解析
服务器·c语言·嵌入式硬件·php·fabric
Zs050928 分钟前
服务器使用率高处理思路
服务器
咯哦哦哦哦31 分钟前
配置VNC sever 6.11.0版本 linux(激活码)
linux·运维·服务器