MySQL 搭建主从报错 1236

错误信息:

Last_IO_Error: Got fatal error 1236 from source when reading data from binary log: 'Could not find first log file name in binary log index file'

大致内容:

MySQL 在尝试从二进制日志(binary log)中读取数据时,无法在其二进制日志索引文件(binary log index file)中找到第一个日志文件的名称。

引起该现象的原因:

1、二进制日志文件或索引损坏丢失

2、磁盘空间不足

解决方法:

1、检查磁盘空间是否充足。如果不足,释放空间后重试

2、生成新的二进制文件

bash 复制代码
# 1、停止同步(从服务器执行)
mysql> stop slave

# 2、关闭并打开新的日志文件(主库执行)
mysql> flush logs;

# 3、查看主库状态(主库执行)
mysql> show master status;
+------------------+----------+--------------+------------------+-------------------+
| File             | Position | Binlog_Do_DB | Binlog_Ignore_DB | Executed_Gtid_Set |
+------------------+----------+--------------+------------------+-------------------+
| slave-bin.000002 |      158 |              |                  |                   |
+------------------+----------+--------------+------------------+-------------------+

# 4、配置同步信息(从库执行)
mysql> change master to master_host="192.168.140.153",master_user="slave",master_password="Slave_123",master_log_file="slave-bin.000002",master_log_pos=158;

# 5、开启同步(从库执行)
mysql> slave start;

# 6、查看从库信息(从库执行)
mysql> show slave status/G;
相关推荐
Q26433650231 分钟前
【有源码】基于springboot的知识产权管理系统-知识产权咨询问答管理系统-知识产权价值评估管理系统
java·spring boot·mysql·spring·毕业设计·javaweb·课程设计
Studying 开龙wu3 分钟前
CVAT 导出崩溃排查实录:一个空壳轨迹引发的连锁反应
数据库·sqlite
PaperData8 小时前
1985-2025年全国区县专利申请与授权面板数据
数据库
snpgroupcn8 小时前
大数据量SAP迁移方案:系统越大,越不能硬搬
数据库·sap
Flynt9 小时前
Redis Cluster主节点挂了,为什么"高可用"还全员掉线?我把三次kill的记录翻出来了
数据库·redis·分布式
笃行3509 小时前
KingbaseES 数据加密全解:从 SSL 到全密态
数据库
Ivanqhz10 小时前
激活函数在 Transformer 中的作用及各种变体简述
java·linux·数据库·人工智能·深度学习
java1234_小锋11 小时前
【技术专题】Mysql8 数据库 - Mysql8 数据类型简介
数据库·mysql
知行EDI11 小时前
知行之桥 MaBang 端口使用指南——Create Order 订单创建篇
java·服务器·数据库
成旭先生11 小时前
【2026】企业信息模糊查询 API 实战:名称、注册号、统一社会信用代码、企业类型与法人一次查全
服务器·数据库·数据服务