【笔记】记一次在linux上通过在线安装mysql报错 CentOS 7 的官方镜像已经不再可用的解决方法+mysql配置

报错(恨恨恨恨恨恨恨!!!!!):

root@localhost \~# sudo yum install mysql-server 已加载插件:fastestmirror, langpacks Determining fastest mirrors Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7\&arch=x86_64\&repo=os\&infra=stock error was 14: curl#6 - "Could not resolve host: mirrorlist.centos.org; 未知的错误" One of the configured repositories failed (未知), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this: 1. Contact the upstream for the repository and get them to fix the problem. 2. Reconfigure the baseurl/etc. for the repository, to point to a working upstream. This is most often useful if you are using a newer distribution release than is supported by the repository (and the packages for the previous distribution release still work). 3. Run the command with the repository temporarily disabled yum --disablerepo=<repoid> ... 4. Disable the repository permanently, so yum won't use it by default. Yum will then just ignore the repository until you permanently enable it again or use --enablerepo for temporary usage: yum-config-manager --disable <repoid> or subscription-manager repos --disable=<repoid> 5. Configure the failing repository to be skipped, if it is unavailable. Note that yum will try to contact the repo. when it runs most commands, so will have to try and fail each time (and thus. yum will be be much slower). If it is a very temporary problem though, this is often a nice compromise: yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true Cannot find a valid baseurl for repo: base/7/x86_64

意思是CentOS 7 的官方镜像已经不再可用,导致 yum 无法从标准的仓库中获取软件包信息

解决方法:

首先,卸载掉你那系统自带的数据库

其次

输入 vim /etc/yum.repos.d/CentOS-Base.repo

编辑这该死的文件

把每个部分**(这里举例base部分)的mirrorlist注释掉**

去掉baseurl的注释并且将其改成baseurl=http://vault.centos.org/$contentdir/$releasever/os/$basearch/

(!!!!!!!!!!!!!!!!!!!!!!!!!!!很重要!!!!!!!!!!!!!!!!!!!!)

esc退出文件 :wq保存

输入

sudo yum install wget

sudo yum install mysql-server

然后mysql!终于!可以!正常!下载了!!!!!!!!!!!!!!!!

配置篇:

输入:sudo grep 'temporary password' /var/log/mysqld.log

获取随机密码 记住 后面要考

输入:sudo mysql_secure_installation

新密码要求:

  • 最少8个字符
  • 至少1个大写字母
  • 至少1个小写字母
  • 至少1个数字
  • 至少1个特殊字符

包含图上的虚红色记号 一共五个问题 我是ynnys

令人感动的All done 来之不易

在输入一次 mysql -u root -p登录mysql

登录成功!

相关推荐
xiaoye-duck21 分钟前
《Linux 网络编程》深入理解五种 IO 模型:从 IO 本质到非阻塞 IO 实战
linux·网络
程序员-Benothing21 分钟前
Linux内核与模块管理:uname、lsmod、modprobe、sysct
linux·运维·数据库
嵌入式小能手22 分钟前
飞凌嵌入式ElfBoard-Shell编程应用实例-使用WiFi拨号上网
linux·服务器·网络
..Dauntless..22 分钟前
【Linux】环境变量
linux·运维·服务器
FED_AF35 分钟前
Linux运维“邪修”功法之正则表达式
linux·运维·正则表达式
xiaoye-duck1 小时前
《Linux 网络编程·加餐》详解 listen 的 backlog 与 TCP 全连接队列
linux·tcp
Vcaker1 小时前
Linux学习33-HPA动态扩缩容及k8s调度策略
linux·运维·学习
yi0111 小时前
LeetCode 134 加油站:从 双循环暴力 演变到 贪心
linux·算法·leetcode
金色光环1 小时前
概率论笔记:连续型随机变量函数的分布与尺度变换 连续型随机变量函数的分布:定义法与公式法推导
笔记·概率论
醇氧1 小时前
CentOS7.9 Yum 安装 Redis6.x(RPM 包,无需编译,推荐 remi 源)
linux·python