ERROR | Web server failed to start. Port 8080 was already in use.

错误提示:

java 复制代码
***************************
APPLICATION FAILED TO START
***************************

Description:

Web server failed to start. Port 8080 was already in use.

Action:

Identify and stop the process that's listening on port 8080 or configure this application to listen on another port.


Process finished with exit code 1

解决方法:

1、确定监听端口8080的进程ID(PID)

java 复制代码
sudo netstat -tulnp | grep :8080
或
sudo lsof -i :8080

2、终止该进程

java 复制代码
sudo kill -9 PID

其中PID是上一步获取到的监听端口8080的进程ID。

如果你想要配置某个服务在启动时不要监听8080端口,你需要查看该服务的配置文件,并根据服务的具体配置方式进行修改。例如,如果是Apache服务器,你可能需要编辑httpd.conf或者相应的虚拟主机配置文件,将监听端口更改为其他未被使用的端口。

请注意,使用kill -9可能不会给予该进程任何清理自身和优雅关闭的机会,应当在确保安全的前提下使用。如果可能,首选使用kill PID来让进程自行关闭。

相关推荐
夜听莺儿鸣15 分钟前
502-003_Linux 中断与异常(一):从Linux角度理解中断与异常
linux·中断与异常·linux中断
自强的小白38 分钟前
核心功能(Service接口)
java·mybatis
杨云龙UP1 小时前
TDengine 3.4.2.8 Community 三节点三副本生产集群部署实战(DNode/MNode/taosAdapter/Explorer)
大数据·linux·运维·数据库·tdengine·时序库
乌暮2 小时前
深入理解 Java 泛型:把「万能盒子」用对、用稳
java·开发语言·后端·学习
向成科技2 小时前
XC3576H工控主板|深度适配Ubuntu 26.04 LTS,释放边缘AI与工业开发新潜能
linux·人工智能·ubuntu·机器人·硬件·主板·边缘ai
大猫和小黄2 小时前
深入理解 Java Optional:从设计哲学到工程实战
java
数据库百宝箱2 小时前
rum&gin索引对比
java·数据库·gin
Fcy6482 小时前
Linux下 进程间关系与守护进程
linux·运维·服务器·守护进程
yychen_java2 小时前
第六篇:Spring AI 实战:将 Java 业务接口封装成企业级 MCP Server
java·人工智能·spring