K8s集群初始化遇到的问题

kubectl describe pod coredns-545d6fc579-s9g5s -n kube-system

找到原因1:CoreDNS Pod 处于 Pending 状态的原因是集群中的节点都带有 node.kubernetes.io/not-ready 污点

journalctl -u kubelet -f

14:57:59.178592 3553 remote_image.go:114] "PullImage from image service failed" err="rpc error: code = Unknown desc = error pulling image configuration: download failed after attempts=6: dial tcp 4.78.139.50:443: connect: connection refused" image="docker.io/calico/cni:v3.25.0"

找到原因2:Kubelet 在尝试从 docker.io 拉取 Calico 的 CNI 镜像时失败,连接被拒绝

查看calico.yaml中所需要的镜像,发现都是从docker hub中拉取的,目前由于政策原因,只能更换加速器

bash 复制代码
[root@k8s-master ~]# grep image calico.yaml | sort | uniq 
          image: docker.io/calico/cni:v3.25.0
          image: docker.io/calico/kube-controllers:v3.25.0
          image: docker.io/calico/node:v3.25.0
          imagePullPolicy: IfNotPresent

解决操作1:添加加速器

bash 复制代码
cat /etc/docker/daemon.json 
{
"registry-mirrors": ["https://b9pmyelo.mirror.aliyuncs.com","https://dockerpull.com","https://docker.aityp.com/"],
"exec-opts": ["native.cgroupdriver=systemd"]
}

之后重新拉取calico镜像

kubectl delete -f calico.yaml

kubectl apply -f calico.yaml

kubectl get pods -n kube-system

calico-node-dzq28 0/1 Init:0/3 0 5m40s

calico-node-vsnwj 0/1 Init:0/3 0 5m40s

**找到原因3:**可以看出有两个clico节点pod尚未初始化成功

kubectl describe pod calico-node-dzq28 -n kube-system

找到原因4: 根据 kubectl describe 的输出,显示 kubelet 一直在尝试拉取 docker.io/calico/cni:v3.25.0 镜像,但没有成功完成拉取。这通常意味着节点无法从 Docker 仓库拉取镜像。

**解决操作2:**前面只更换了master节点中docker的操作,故节点还是无法拉取镜像,只需给节点添加相应镜像

添加后,重启docker,在重新执行操作1,所有pod都是runnning

相关推荐
程序员清风8 小时前
Docker、Nginx 与 Kubernetes 部署 AI 后端服务
nginx·docker·kubernetes
Zhu7589 小时前
离线二进制部署-Kubernetes-v1.36.4
容器·贪心算法·kubernetes
天衍四九-10 小时前
Docker容器实战系列(八):Docker生产最佳实践与避坑指南,系列终章
运维·docker·容器
Zhou14113612 小时前
Docker_03_DockerCompose多容器编排
运维·docker·容器
程序猿阿越12 小时前
containerd如何拉取镜像
后端·kubernetes·源码阅读
Elastic 中国社区官方博客12 小时前
Kubernetes attributes processor v1:它对 EDOT Collector 意味着什么
java·大数据·elasticsearch·搜索引擎·贪心算法·kubernetes·全文检索
啊哈一半醒14 小时前
Docker 底层知识:从 Namespace 到 UnionFS
运维·docker·容器
分布式存储与RustFS15 小时前
升级 RustFS 二进制不停机:一条一条换,留一条退路
运维·云原生·开源·对象存储·分布式存储·s3·性能基准
fruge16 小时前
飞牛OS部署Flare导航页:Docker Compose、YAML书签配置与cpolar公网访问
运维·docker·容器
xiaoligangting16 小时前
太原防火岗亭
云原生