RKE部署k8s

移除docker(非必要)

bash 复制代码
rm -rf /etc/docker
rm -rf /run/docker
rm -rf /var/lib/dockershim
rm -rf /var/lib/docker
yum list installed | grep docker
yum remove ***

rke部署k8s集群

bash 复制代码
cat > /etc/sysctl.conf << EFO
net.ipv4.ip_forward = 1
net.bridge.bridge-nf-call-ip6tables = 1
net.bridge.bridge-nf-call-iptables = 1
EFO
modprobe br_netfilter
sysctl -p
yum-config-manager  --add-repo  http://mirrors.aliyun.com/docker-ce/linux/centos/docker-ce.repo
yum install -y docker-ce-20.10.9-3.el7
useradd rke && usermod -aG docker rke
./rke_linux-amd64 config --name cluster.yml
./rke_linux-amd64 up

如果需要增加node节点或者etcd节点,只需要更改cluster.yml后rke up --update-only即可

安装kubectl

bash 复制代码
cat > /etc/yum.repos.d/kubenetes.repo <<EOF

[kubernetes]
name=Kubernetes
baseurl=https://mirrors.aliyun.com/kubernetes/yum/repos/kubernetes-el7-x86_64/
gpgcheck=1
gpgkey=https://mirrors.aliyun.com/kubernetes/yum/doc/rpm-package-key.gpg
enabled=1 
EOF

安装成功之后会在当前目录生成kube_config_cluster.yml文件,此为k8s的kube_config文件,需要配置kubectl默认读取文件才可执行kubectl命令进行查询

bash 复制代码
kubectl --kubeconfig kube_config_cluster.yml get node
bash 复制代码
yum install -y kubectl
kubectl get node

安装helm

bash 复制代码
wget https://get.helm.sh/helm-v3.11.3-linux-amd64.tar.gz
cd linux-amd64
cp helm /usr/bin/

新增节点

复制代码
更改文件并只更新即可
./rke_linux-amd64 up --update-only

安装rancher

bash 复制代码
helm repo add rancher-latest https://releases.rancher.com/server-charts/latest

kubectl create namespace cattle-system

kubectl apply -f https://github.com/cert-manager/cert-manager/releases/download/v1.11.0/cert-manager.crds.yaml

helm repo add jetstack https://charts.jetstack.io

helm repo update

helm install cert-manager jetstack/cert-manager \
  --namespace cert-manager \
  --create-namespace \
  --version v1.11.0
bash 复制代码
helm install rancher rancher-latest/rancher \
  --namespace cattle-system \
  --set hostname=<IP_OF_LINUX_NODE>.sslip.io \
  --set replicas=1 \
  --set bootstrapPassword=<PASSWORD_FOR_RANCHER_ADMIN>

此处密码最少12个字符

FAQ

如果出现错误Error: INSTALLATION FAILED: execution error at (rancher/templates/validate-psp-install.yaml:4:5): The target cluster does not have the PodSecurityPolicy API resource. Please disable PSPs in this chart before proceeding.

则在install的时候加上--set global.cattle.psp.enabled=false选项

FATA[0001] Cluster must have at least one etcd plane host: failed to connect to the following etcd host(s) []

复制代码
yum update openssh -y
vim /etc/ssh/sshd_config
	AllowTcpForwarding yes
相关推荐
openFuyao11 小时前
新增Agent沙箱调度能力!openFuyao v26.09社区发行版上线,AI原生基础设施能力进一步升级
云原生·ai-native·ai推理·openfuyao·多样化算力集群软件
谢亮_vipxieliang11 小时前
Kubernetes 1.36 深度解读:从 kubelet 安全到 GPU 原生调度的 70 项改进
安全·kubernetes·kubelet
阿里云云原生14 小时前
云效工作项智能优化:先澄清,再开工
云原生
阿里云云原生14 小时前
阿里云日志服务 SLS 全新升级,打造 Agent 时代的智能数据引擎
云原生
阿里云云原生14 小时前
从“治已病”到“治未病”:浩瀚能源与阿里云共建充电补能异地双活高可用体系实践
云原生
wzq11_66614 小时前
kubernetes集群——灰度发布
云原生·容器·kubernetes
阿里云云原生16 小时前
阿里云发布 Alibaba Cloud AI Agent Handbook,阐述“智能面积”
云原生
灯澜忆梦17 小时前
【docker】#1 | Docker 初识
运维·docker·容器
骑着蜗牛撵大象32718 小时前
穿越 Docker 内核迷雾:镜像分层的叠加态与卷挂载的空间穿梭
运维·docker·容器·联合文件系统·卷挂载·镜像分层·存储驱动
吴声子夜歌19 小时前
Docker入门与实战——Docker数据管理
docker·容器