浙大版《C语言程序设计(第3版)》题目集

练习5-2 找两个数中最大者

本题要求对两个整数a和b,输出其中较大的数。

函数接口定义:

int max( int a, int b );

其中ab是用户传入的参数,函数返回的是两者中较大的数。

裁判测试程序样例:

#include <stdio.h>

int max( int a, int b );

int main() {

int a, b;

scanf("%d %d", &a, &b);

printf("max = %d\n", max(a, b));

return 0; }

/* 你的代码将被嵌在这里 */

输入样例:

复制代码
-5 8

输出样例:

复制代码
max = 8

#include <stdio.h>

#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int max(int a,int b);

int main(int argc, char *argv[]) {

int a,b;

scanf("%d %d",&a,&b);

printf("max = %d\n",max(a,b));

return 0;

}

int max(int a,int b){

if(a>b){

return a;

}

return b;

}

相关推荐
算AI13 小时前
人工智能+牙科:临床应用中的几个问题
人工智能·算法
懒羊羊大王&14 小时前
模版进阶(沉淀中)
c++
似水এ᭄往昔14 小时前
【C语言】文件操作
c语言·开发语言
owde15 小时前
顺序容器 -list双向链表
数据结构·c++·链表·list
GalaxyPokemon15 小时前
Muduo网络库实现 [九] - EventLoopThread模块
linux·服务器·c++
W_chuanqi15 小时前
安装 Microsoft Visual C++ Build Tools
开发语言·c++·microsoft
hyshhhh15 小时前
【算法岗面试题】深度学习中如何防止过拟合?
网络·人工智能·深度学习·神经网络·算法·计算机视觉
蒙奇D索大15 小时前
【数据结构】第六章启航:图论入门——从零掌握有向图、无向图与简单图
c语言·数据结构·考研·改行学it
tadus_zeng16 小时前
Windows C++ 排查死锁
c++·windows
EverestVIP16 小时前
VS中动态库(外部库)导出与使用
开发语言·c++·windows