练习5-2 找两个数中最大者
本题要求对两个整数a和b,输出其中较大的数。
函数接口定义:
int max( int a, int b );
其中a
和b
是用户传入的参数,函数返回的是两者中较大的数。
裁判测试程序样例:
#include <stdio.h>
int max( int a, int b );
int main() {
int a, b;
scanf("%d %d", &a, &b);
printf("max = %d\n", max(a, b));
return 0; }
/* 你的代码将被嵌在这里 */
输入样例:
-5 8
输出样例:
max = 8
#include <stdio.h>
#include <stdlib.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int max(int a,int b);
int main(int argc, char *argv[]) {
int a,b;
scanf("%d %d",&a,&b);
printf("max = %d\n",max(a,b));
return 0;
}
int max(int a,int b){
if(a>b){
return a;
}
return b;
}