浙大版《C语言程序设计(第3版)》题目集

练习5-2 找两个数中最大者

本题要求对两个整数a和b,输出其中较大的数。

函数接口定义:

int max( int a, int b );

其中ab是用户传入的参数,函数返回的是两者中较大的数。

裁判测试程序样例:

#include <stdio.h>

int max( int a, int b );

int main() {

int a, b;

scanf("%d %d", &a, &b);

printf("max = %d\n", max(a, b));

return 0; }

/* 你的代码将被嵌在这里 */

输入样例:

-5 8

输出样例:

max = 8

#include <stdio.h>

#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int max(int a,int b);

int main(int argc, char *argv[]) {

int a,b;

scanf("%d %d",&a,&b);

printf("max = %d\n",max(a,b));

return 0;

}

int max(int a,int b){

if(a>b){

return a;

}

return b;

}

相关推荐
刚学HTML15 分钟前
leetcode 05 回文字符串
算法·leetcode
蜀黍@猿19 分钟前
【C++ 基础】从C到C++有哪些变化
c++
Am心若依旧40920 分钟前
[c++11(二)]Lambda表达式和Function包装器及bind函数
开发语言·c++
zh路西法30 分钟前
【C++决策和状态管理】从状态模式,有限状态机,行为树到决策树(一):从电梯出发的状态模式State Pattern
c++·决策树·状态模式
stm 学习ing32 分钟前
HDLBits训练5
c语言·fpga开发·fpga·eda·hdlbits·pld·hdl语言
AC使者35 分钟前
#B1630. 数字走向4
算法
冠位观测者39 分钟前
【Leetcode 每日一题】2545. 根据第 K 场考试的分数排序
数据结构·算法·leetcode
轩辰~44 分钟前
网络协议入门
linux·服务器·开发语言·网络·arm开发·c++·网络协议
lxyzcm1 小时前
C++23新特性解析:[[assume]]属性
java·c++·spring boot·c++23
蜀黍@猿1 小时前
C/C++基础错题归纳
c++