P1217 [USACO1.5] 回文质数 Prime Palindromes

题目描述

因为 151 151 151 既是一个质数又是一个回文数(从左到右和从右到左是看一样的),所以 151 151 151 是回文质数。

写一个程序来找出范围 [ a , b ] ( 5 ≤ a < b ≤ 100 , 000 , 000 ) [a,b] (5 \le a < b \le 100,000,000) [a,b](5≤a<b≤100,000,000)(一亿)间的所有回文质数。

输入格式

第一行输入两个正整数 a a a 和 b b b。

输出格式

输出一个回文质数的列表,一行一个。

样例 #1

样例输入 #1

5 500

样例输出 #1

5
7
11
101
131
151
181
191
313
353
373
383

提示

Hint 1: Generate the palindromes and see if they are prime.

提示 1: 找出所有的回文数再判断它们是不是质数(素数).

Hint 2: Generate palindromes by combining digits properly. You might need more than one of the loops like below.

提示 2: 要产生正确的回文数,你可能需要几个像下面这样的循环。

题目翻译来自NOCOW。

USACO Training Section 1.5

产生长度为 5 5 5 的回文数:

cpp 复制代码
for (d1 = 1; d1 <= 9; d1+=2) {    // 只有奇数才会是素数
     for (d2 = 0; d2 <= 9; d2++) {
         for (d3 = 0; d3 <= 9; d3++) {
           palindrome = 10000*d1 + 1000*d2 +100*d3 + 10*d2 + d1;//(处理回文数...)
         }
     }
 }

思路

参考大佬题解

代码

cpp 复制代码
#include<iostream>
#include<algorithm>
#include<cstring>
#include<vector>
#define endl '\n'
using namespace std;

int a, b;

// 判断位数
// 这里用到最重要的一个性质:
// 所有偶数位的回文数(除了11)必然不是质数。
bool check_weishu(int x) {

	// 如果是偶数位,必然不是质数,返回false
	if ((x >= 1000 & x <= 9999) || (x >= 100000 && x <= 999999)) {
		return false;
	}

	return true;
}

// 判断回文
bool check_huiwen(int x) {
	vector<int> a;

	while (x) {
		a.push_back(x % 10);
		x /= 10;
	}

	int len = a.size();
	for (int i = 0; i < len / 2; i++) {
		if (a[i] != a[len - i - 1]) {
			return false;
		}
	}
	return true;
}

// 判断质数
bool check_zhishu(int x) {

	if (x < 2) {
		return false;
	}

	for (int i = 2; i <= x / i; i++) {
		if (x % i == 0) {
			return false;
		}
	}
	return true;
}

int main() {
	ios::sync_with_stdio(false), cin.tie(nullptr), cout.tie(nullptr);
	cin >> a >> b;

	// 这里是为了从奇数开始枚举,因为偶数肯定不是质数(本题范围不包括2)
	if (a % 2 == 0) {
		a++;
	}

	// 本题范围最大到10^8次方(9位),8位的回文数一定不是质数,因此最多只需要枚举到9999999(7位)
	b = min(b, 9999999);

	for (int i = a; i <= b; i += 2) {

		// 因为判断回文快,而回文数又少,所以先判断回文,再判断质数
		if (check_weishu(i) && check_huiwen(i) && check_zhishu(i)) {
			cout << i << endl;
		}
	}

	return 0;
}
相关推荐
EterNity_TiMe_8 分钟前
【论文复现】(CLIP)文本也能和图像配对
python·学习·算法·性能优化·数据分析·clip
机器学习之心18 分钟前
一区北方苍鹰算法优化+创新改进Transformer!NGO-Transformer-LSTM多变量回归预测
算法·lstm·transformer·北方苍鹰算法优化·多变量回归预测·ngo-transformer
yyt_cdeyyds29 分钟前
FIFO和LRU算法实现操作系统中主存管理
算法
alphaTao1 小时前
LeetCode 每日一题 2024/11/18-2024/11/24
算法·leetcode
kitesxian1 小时前
Leetcode448. 找到所有数组中消失的数字(HOT100)+Leetcode139. 单词拆分(HOT100)
数据结构·算法·leetcode
VertexGeek2 小时前
Rust学习(八):异常处理和宏编程:
学习·算法·rust
石小石Orz2 小时前
Three.js + AI:AI 算法生成 3D 萤火虫飞舞效果~
javascript·人工智能·算法
jiao_mrswang3 小时前
leetcode-18-四数之和
算法·leetcode·职场和发展
qystca3 小时前
洛谷 B3637 最长上升子序列 C语言 记忆化搜索->‘正序‘dp
c语言·开发语言·算法
薯条不要番茄酱3 小时前
数据结构-8.Java. 七大排序算法(中篇)
java·开发语言·数据结构·后端·算法·排序算法·intellij-idea