链表Set_LinkList(并集)

并集是把两个集合合并,去除重复元素后组成的集合。

通过键盘输入将两个集合保存在链表A和链表B中,再创建一个链表C用于保存集合A、B的并集,将链表C打印输出。

提示:

1.相对于上一题(链表Set_LinkList(建立)),本题只需遍历已保存的链表A、B,将遍历到的当前值插入到链表C中;

2.为遍历取出链表数据,需要编写取值函数GetElem(LinkList L, int i),该函数功能为按序号返回数据元素,注意序号从1开始;

3.遍历链表需要知道链表长度,请自行编写ListLength()函数。

4.用户从键盘输入集合A、B,输入数据为整数,输入以-1结束。

输入格式:

第一行输入集合A,第二行输入集合B。

输出格式:

输出集合A、B的并集C

输入样例:

在这里给出一组输入。例如:

9 4 0 7 3 6 5 -1
1 5 6 8 4 7 0 -1

输出样例:

在这里给出相应的输出。例如:

9 4 0 7 3 6 5 1 8

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

cpp 复制代码
#include <bits/stdc++.h>
using namespace std;
typedef int ElemType;
struct node{
    ElemType Data;
    struct node* next;
};
typedef struct node* Set_LinkList;
Set_LinkList init(){
    Set_LinkList L = (Set_LinkList)malloc(sizeof(struct node));
    L->Data = -1;
    L->next = NULL;
    return L;
}
int ListLength(Set_LinkList L){
    int counts = 0;
    Set_LinkList p = L->next;
    while(p != NULL){
        counts++;
        p = p->next;
    }
    return counts;
}
ElemType GetElem(Set_LinkList L, int i){
    int counts = 0;
    Set_LinkList p = L->next;
    while(p != NULL){
        counts++;
        if(counts == i){
            return p->Data;
        }
        p = p->next;
    }
    return -1;
}
void CreatList(Set_LinkList L, ElemType x){
    Set_LinkList p = L->next;
    if(p == NULL){
        Set_LinkList newnode = (Set_LinkList)malloc(sizeof(struct node));
        newnode->Data = x;
        newnode->next = NULL;
        L->next = newnode;
        return;
    }
    while(p->next != NULL){
        p = p->next;
    }
    Set_LinkList newnode = (Set_LinkList)malloc(sizeof(struct node));
    newnode->Data = x;
    newnode->next = NULL;
    p->next = newnode;
    return;
}
void display(Set_LinkList L){
    Set_LinkList p = L->next;
    if(p == NULL){
        cout<<"NULL";
        return;
    }
    while(p->next != NULL){
        cout<<p->Data<<' ';
        p = p->next;
    }
    cout<<p->Data;
}
void insert(Set_LinkList L, ElemType e){
    Set_LinkList p = L->next;
    if(p == NULL){
        Set_LinkList newnode = (Set_LinkList)malloc(sizeof(struct node));
        L->next = newnode;
        newnode->Data = e;
        newnode->next = NULL;
        return;
    }
    while(p->next != NULL){
        if(p->Data == e){
            return;
        }
        p = p->next;
    }
    if(p->Data == e){
        return;
    }
    Set_LinkList newnode = (Set_LinkList)malloc(sizeof(struct node));
    p->next = newnode;
    newnode->Data = e;
    newnode->next = NULL;
    return;
}
int main(){
    int x;
    Set_LinkList A = init();
    Set_LinkList B = init();
    cin>>x;
    while(x != -1){
        CreatList(A , x);
        cin>>x;
    }
    cin>>x;
    while(x != -1){
        CreatList(B , x);
        cin>>x;
    }
    int longA = ListLength(A);
    int longB = ListLength(B);
    Set_LinkList C = init();
    for(int i = 1;i <= longA;i++){
        insert(C,GetElem(A,i));
    }
    for(int i = 1;i <= longB;i++){
        insert(C,GetElem(B,i));
    }
    display(C);
    return 0;
}
相关推荐
xiaoshiguang34 小时前
LeetCode:222.完全二叉树节点的数量
算法·leetcode
爱吃西瓜的小菜鸡4 小时前
【C语言】判断回文
c语言·学习·算法
别NULL4 小时前
机试题——疯长的草
数据结构·c++·算法
TT哇4 小时前
*【每日一题 提高题】[蓝桥杯 2022 国 A] 选素数
java·算法·蓝桥杯
yuanbenshidiaos5 小时前
C++----------函数的调用机制
java·c++·算法
唐叔在学习5 小时前
【唐叔学算法】第21天:超越比较-计数排序、桶排序与基数排序的Java实践及性能剖析
数据结构·算法·排序算法
ALISHENGYA6 小时前
全国青少年信息学奥林匹克竞赛(信奥赛)备考实战之分支结构(switch语句)
数据结构·算法
chengooooooo6 小时前
代码随想录训练营第二十七天| 贪心理论基础 455.分发饼干 376. 摆动序列 53. 最大子序和
算法·leetcode·职场和发展
jackiendsc6 小时前
Java的垃圾回收机制介绍、工作原理、算法及分析调优
java·开发语言·算法
游是水里的游7 小时前
【算法day20】回溯:子集与全排列问题
算法