在 /var/cache/apt/archives/ 上没有足够的可用空间的解决方法

问题

apt-get upgrade 更新软件包时,提示没有足够的空间。

分析

一般来说,除非下载的文件过于大,整个服务器的内存都不够用,否则可以改变默认的下载路径进行下载。

解决方法

  1. 找一个空间足够的目录,新建一个单独的目录。
powershell 复制代码
mkdir /your_path/debs
  1. 删除已有的 archives 文件夹。
powershell 复制代码
sudo rm -rf /var/cache/apt/archives
  1. 将/var/cache/apt/archives/换成指向这个目录的软链接。
powershell 复制代码
sudo ln -s /your_path/debs /var/cache/apt/archives

之后就可以用 apt-get install package 安装了。此时,安装包会下载至 /your_path/debs。

相关推荐
vortex52 分钟前
常用终端模拟器全面对比:Kitty、WezTerm、Ghostty 与 Konsole
linux
我命由我123458 分钟前
Git 推送报错:error: src refspec main does not match any
运维·git·gitee·github·运维开发·学习方法·版本控制
骇客野人9 分钟前
测试环境MySQL迁移Vastbase(海量数据库)完整改造与落地实施方案
运维·服务器
迪康Defender29 分钟前
终端安全实战:如何高效解决企业U盘泄密与管控难题
运维·网络·安全·web安全·终端安全管理
Wang's Blog1 小时前
Java 项目实战: 外卖平台-删除分类的关联校验与自定义业务异常
java·服务器·项目开发
INGNIGHT1 小时前
270 · 电话号码的字母组合II(Trie)
linux·算法
zly35001 小时前
VMware Converter Standalone 物理机转化为虚拟机后源1硬盘变成了2个硬盘(2个硬盘文件)虚拟机无法启动。
linux·运维·服务器
马可家的菠萝1 小时前
你收藏的资料,有多少真的被你第二次打开过?
笔记·知识管理·效率提升·个人知识库
智能运维指南1 小时前
2026 企业智能运维平台选型:私有化、信创、全链路打通该怎么权衡?
运维·嘉为蓝鲸·aiops平台·一体化运维平台
学习中的码虫2 小时前
网络编程5
服务器·网络