华为配置手工负载分担模式链路聚合实验

目录

组网需求

配置思路

操作步骤

配置文件


组网图形

图1配置手工负载分担模式链路聚合组网图

  • 组网需求
  • 配置思路
  • 操作步骤
  • 配置文件
组网需求

图1所示,AC1和AC2通过以太链路分别都连接VLAN10和VLAN20,且AC1和AC2之间有较大的数据流量。

用户希望AC1和AC2之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

配置思路

采用如下的思路配置负载分担链路聚合:

  1. 创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。

    接口缺省都加入了VLAN1,因此加入Eth-Trunk前建议先将接口从VLAN1中退出或将接口Shutdown,避免出现广播风暴。

  2. 创建VLAN并将接口加入VLAN。

  3. 配置负载分担方式,实现流量在Eth-Trunk各成员接口间的负载分担,增加可靠性。

操作步骤
  1. 在AC1创建Eth-Trunk接口并加入成员接口。AC2配置与AC1类似,不再赘述。

    bash 复制代码
    <HUAWEI> system-view
    [HUAWEI] sysname AC1
    [AC1] interface Eth-Trunk1
    [AC1-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3
    [AC1-Eth-Trunk1] quit
  2. 创建VLAN并将接口加入VLAN。AC2配置与AC1类似,不再赘述。

    bash 复制代码
    # 创建VLAN10和VLAN20并分别加入接口。
    
    [AC1] vlan batch 10 20
    [AC1] interface gigabitethernet 0/0/4
    [AC1-GigabitEthernet0/0/4] port link-type trunk
    [AC1-GigabitEthernet0/0/4] port trunk allow-pass vlan 10
    [AC1-GigabitEthernet0/0/4] quit
    [AC1] interface gigabitethernet 0/0/5
    [AC1-GigabitEthernet0/0/5] port link-type trunk
    [AC1-GigabitEthernet0/0/5] port trunk allow-pass vlan 20
    [AC1-GigabitEthernet0/0/5] quit
    
    
    # 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。
    
    [AC1] interface Eth-Trunk1
    [AC1-Eth-Trunk1] port link-type trunk
    [AC1-Eth-Trunk1] port trunk allow-pass vlan 10 20
  3. 配置Eth-Trunk1的负载分担方式。AC2配置与AC1类似,不再赘述。

    bash 复制代码
    [AC1-Eth-Trunk1] load-balance src-dst-mac
    [AC1-Eth-Trunk1] quit
  4. 验证配置结果

    bash 复制代码
    在任意视图下执行display eth-trunk 1命令,检查Eth-Trunk是否创建成功,及成员接口是否正确加入。
    
    [AC1] display eth-trunk 1
    Eth-Trunk1's state information is: 
    WorkingMode: NORMAL         Hash arithmetic: According to src-dst-mac            
    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8                
    Operate status: up          Number Of Up Port In Trunk: 3
    --------------------------------------------------------------------------------
    PortName                      Status      Weight
    GigabitEthernet0/0/1          Up          1
    GigabitEthernet0/0/2          Up          1
    GigabitEthernet0/0/3          Up          1

    从以上信息看出Eth-Trunk 1中包含3个成员接口GigabitEthernet0/0/1、GigabitEthernet0/0/2和GigabitEthernet0/0/3。成员接口的状态都为Up。

配置文件
bash 复制代码
AC1的配置文件

#
sysname AC1
#
vlan batch 10 20
# 
interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 10 20
 load-balance src-dst-mac 
# 
interface GigabitEthernet0/0/1 
 eth-trunk 1
# 
interface GigabitEthernet0/0/2 
 eth-trunk 1
# 
interface GigabitEthernet0/0/3 
 eth-trunk 1
#
interface GigabitEthernet0/0/4 
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/5 
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return
AC2的配置文件

#
sysname AC2
#
vlan batch 10 20
# 
interface Eth-Trunk1
 port link-type trunk 
 port trunk allow-pass vlan 10 20
 load-balance src-dst-mac 
# 
interface GigabitEthernet0/0/1 
 eth-trunk 1
# 
interface GigabitEthernet0/0/2 
 eth-trunk 1
# 
interface GigabitEthernet0/0/3 
 eth-trunk 1
#
interface GigabitEthernet0/0/4 
 port link-type trunk 
 port trunk allow-pass vlan 10
#
interface GigabitEthernet0/0/5 
 port link-type trunk 
 port trunk allow-pass vlan 20
#
return
相关推荐
JunLan~1 小时前
Rocky Linux 系统安装/部署 Docker
linux·docker·容器
吾日三省吾码2 小时前
JVM 性能调优
java
麻瓜也要学魔法2 小时前
链路状态路由协议-OSPF
网络
方竞2 小时前
Linux空口抓包方法
linux·空口抓包
Estar.Lee2 小时前
查手机号归属地免费API接口教程
android·网络·后端·网络协议·tcp/ip·oneapi
傻啦嘿哟3 小时前
代理IP在后端开发中的应用与后端工程师的角色
网络·网络协议·tcp/ip
弗拉唐3 小时前
springBoot,mp,ssm整合案例
java·spring boot·mybatis
Red Red3 小时前
网安基础知识|IDS入侵检测系统|IPS入侵防御系统|堡垒机|VPN|EDR|CC防御|云安全-VDC/VPC|安全服务
网络·笔记·学习·安全·web安全
海岛日记3 小时前
centos一键卸载docker脚本
linux·docker·centos