CentOS下安装ElasticSearch7.9.2(无坑版)

准备目录

搞一个自己喜欢的目录

shell 复制代码
mkdir /usr/local/app

切换到该目录

shell 复制代码
cd /usr/local/app

下载

shell 复制代码
wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-7.9.2-linux-x86_64.tar.gz

选择其他版本

点击进入官网

https://www.elastic.co/guide/en/elasticsearch/reference/7.9/getting-started-install.html

下载地址

https://www.elastic.co/cn/downloads/past-releases#elasticsearch

解压

shell 复制代码
tar -zxvf elasticsearch-7.9.2-linux-x86_64.tar.gz

切换到bin目录

shell 复制代码
cd elasticsearch-7.9.2/bin/

启动

进入安装目录的bin目录下,执行以下命令启动服务。这里为了观察效果使用前台方式启动,如果想要以后台进程的方式启动,则需要在后面加上-d参数

shell 复制代码
./elasticsearch

关闭

如果后端启动,需要关闭es

  • 列出es进程
shell 复制代码
ps aux|grep elasticsearch
  • kill第一个进程
shell 复制代码
kill -9 进程号

报错处理

!!!不出意外的话,会出错。

新建es用户

shell 复制代码
adduser es

授权

shell 复制代码
chown -R es /usr/local/app/elasticsearch-7.9.2/

注意

JDK 版本:安装 ElasticSearch7.9.2 不需要额外配置 JDK 环境,即使本地 JDK 版本不匹配也不影响启动。

配置允许外网访问

切换到 config 目录下,打开配置文件

shell 复制代码
vim elasticsearch.yml

修改如下:

当前节点的名称

node.name: node-1

修改绑定地址,默认为本机地址,此时只能在本机访问ElasticSearch服务,想要所有主机都能访问,则修改为0.0.0.0

network.host: 0.0.0.0

cluster.initial_master_nodes: "node-1"

切换用户

shell 复制代码
su - es
shell 复制代码
cd /usr/local/app/elasticsearch-7.9.2/bin/
shell 复制代码
./elasticsearch

启动后,可能会出现一些错误,如果 没有请忽略。

启动报错处理

1: max file descriptors 4096 for elasticsearch process is too low, increase to at least 65535

解决方式:

shell 复制代码
vim /etc/security/limits.conf
# 加入以下配置:
* soft nofile 65535
* hard nofile 65535

!!!不要忘记使用root用户修改后,重新切换到用户 es 之后才会生效

特别注意: 1:* 代表所有用户生效 2:es 代表 es 用户生效

2: max virtual memory areas vm.max_map_count 65530 is too low, increase to at least 262144 解决方式:

shell 复制代码
vim /etc/sysctl.conf 
# 加入以下配置:
# 限制一个进程可以拥有的VMA(虚拟内存区域)的数量
vm.max_map_count=655360

刷新配置生效

javascript 复制代码
sysctl -p

3: the default discovery settings are unsuitable for production use; at least one of discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes must be configured

解决方式:

javascript 复制代码
vim ../config/elasticsearch.yml

​

到此就可以启动成功了

开启防火墙9200

shell 复制代码
firewall-cmd --zone=public --add-port=9200/tcp --permanent
systemctl restart firewalld.service

如果是云服务,在安全组中开启9200端口

测试成功

elasticsearch的优化

内存优化(土豪请忽略)

常用的配置在两个文件里,分别是 elasticsearch.yml 和 jvm.options(配置内存)

jvm.options主要是进行内存相关配置,elasticsearch默认给的1g。

官方建议分配给es的内存不要超出系统内存的50%,预留一半给Lucene,因为Lucene会缓存segment数据提升检索性能;

内存配置不要超过32g,如果你的服务器内存没有远远超过64g,那么不建议将es的jvm内存设置为32g,因为超过32g后每个jvm对象指针的长度会翻倍,导致内存与cpu的开销增大。

但是!!!我的服务器只有2G,后续我还要安装kibana,为了能跑起来,我改了256M。

相关推荐
虎头金猫4 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
AI职业加油站4 天前
AI智能体应用工程师证书:政策红利下的职业新风口
大数据·运维·人工智能·学习·职场发展
此冬歌咏4 天前
K8s 节点故障实战:优雅驱逐 31 秒,硬故障 331 秒,以及那个永远 Pending 的 Pod
运维·k8s
-梅4 天前
linux(8) 软硬链接
linux·运维·服务器
张洛闻Eren4 天前
k8s云原生【第十课】:水平 Pod 自动扩缩容
运维·数据库·云原生·kubernetes·github
其实防守也摸鱼4 天前
内网穿透与反向代理:原理、工具与实战指南
android·大数据·运维·安全·网络安全·自动化·渗透
布裘4 天前
【银河麒麟】V4桌面图标消失,右击鼠标没反应排查
运维·银河麒麟·桌面环境
懂软件的胡子个哥4 天前
微信机器人为什么需要“回复候选”而不是所有 AI 内容直接发送
运维·微信·自动化·wechatapi·个人微信号二次开发
云贝贝贝4 天前
腾讯云 TDSQL(MySQL 版)性能优化与慢查询排障实战 6 招
运维·腾讯云
Lsetea4 天前
证书没到期却报certificate has expired:OpenSSL定位中间证书与系统时间
运维·https·ssl证书·openssl·证书链