7-12 检查密码

7-12 检查密码

作者 陈越

单位 浙江大学

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

in 复制代码
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

out 复制代码
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

代码

c++ 复制代码
#include <bits/stdc++.h>
using namespace std;

bool ifValid(const string &str)
{
    regex pattern1("^[a-zA-Z0-9.]+$");
    regex pattern2("^[a-zA-Z0-9]+$");
    return regex_match(str, pattern1) || regex_match(str, pattern2);
}

bool ifOnlyLetter(const string &str)
{
    regex pattern("^[a-zA-Z.]+$");
    return regex_match(str, pattern);
}

bool ifOnlyNum(const string &str)
{
    regex pattern("^[0-9.]+$");
    return regex_match(str, pattern);
}

string justifyPassword(string password)
{
    if (password.length() < 6)
        return "Your password is tai duan le.";
    else if (!ifValid(password))
        return "Your password is tai luan le.";
    else if (ifOnlyLetter(password))
        return "Your password needs shu zi.";
    else if (ifOnlyNum(password))
        return "Your password needs zi mu.";
    else
        return "Your password is wan mei.";
}

int main()
{
    int N;
    cin >> N;
    getchar();
    while (N--)
    {
        string tempStr;
        getline(cin, tempStr);
        // cout << tempStr.length();
        cout << justifyPassword(tempStr) << endl;
    }
    return 0;
}

优化代码

c++ 复制代码
#include <bits/stdc++.h>
using namespace std;

bool ifValid(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isalnum(c) || c == '.'; });
}

bool ifOnlyLetter(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isalpha(c) || c == '.'; });
}

bool ifOnlyNum(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isdigit(c) || c == '.'; });
}

string justifyPassword(const string &password)
{
    if (password.length() < 6)
        return "Your password is tai duan le.";
    if (!ifValid(password))
        return "Your password is tai luan le.";
    if (ifOnlyLetter(password))
        return "Your password needs shu zi.";
    if (ifOnlyNum(password))
        return "Your password needs zi mu.";
    return "Your password is wan mei.";
}

int main()
{
    int N;
    cin >> N;
    cin.ignore();
    while (N--)
    {
        string tempStr;
        getline(cin, tempStr);
        cout << justifyPassword(tempStr) << endl;
    }
    return 0;
}
  • 不用复杂的正则表达式判断密码是否合法,而是运用了三个函数isalnum()判断是否为字母或数字,isalpha()判断是否为字母,isdigit()判断是否为数字,加上all_of,对整个字符串进行检查。
  • 使用cin.ignore()而不是getchar()来读取缓冲区的换行符
相关推荐
A懿轩A37 分钟前
C/C++ 数据结构与算法【数组】 数组详细解析【日常学习,考研必备】带图+详细代码
c语言·数据结构·c++·学习·考研·算法·数组
古希腊掌管学习的神38 分钟前
[搜广推]王树森推荐系统——矩阵补充&最近邻查找
python·算法·机器学习·矩阵
云边有个稻草人41 分钟前
【优选算法】—复写零(双指针算法)
笔记·算法·双指针算法
半盏茶香42 分钟前
在21世纪的我用C语言探寻世界本质 ——编译和链接(编译环境和运行环境)
c语言·开发语言·c++·算法
忘梓.2 小时前
解锁动态规划的奥秘:从零到精通的创新思维解析(3)
算法·动态规划
tinker在coding4 小时前
Coding Caprice - Linked-List 1
算法·leetcode
XH华8 小时前
初识C语言之二维数组(下)
c语言·算法
南宫生8 小时前
力扣-图论-17【算法学习day.67】
java·学习·算法·leetcode·图论
不想当程序猿_9 小时前
【蓝桥杯每日一题】求和——前缀和
算法·前缀和·蓝桥杯
落魄君子9 小时前
GA-BP分类-遗传算法(Genetic Algorithm)和反向传播算法(Backpropagation)
算法·分类·数据挖掘