7-12 检查密码

7-12 检查密码

作者 陈越

单位 浙江大学

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

in 复制代码
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

out 复制代码
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

代码

c++ 复制代码
#include <bits/stdc++.h>
using namespace std;

bool ifValid(const string &str)
{
    regex pattern1("^[a-zA-Z0-9.]+$");
    regex pattern2("^[a-zA-Z0-9]+$");
    return regex_match(str, pattern1) || regex_match(str, pattern2);
}

bool ifOnlyLetter(const string &str)
{
    regex pattern("^[a-zA-Z.]+$");
    return regex_match(str, pattern);
}

bool ifOnlyNum(const string &str)
{
    regex pattern("^[0-9.]+$");
    return regex_match(str, pattern);
}

string justifyPassword(string password)
{
    if (password.length() < 6)
        return "Your password is tai duan le.";
    else if (!ifValid(password))
        return "Your password is tai luan le.";
    else if (ifOnlyLetter(password))
        return "Your password needs shu zi.";
    else if (ifOnlyNum(password))
        return "Your password needs zi mu.";
    else
        return "Your password is wan mei.";
}

int main()
{
    int N;
    cin >> N;
    getchar();
    while (N--)
    {
        string tempStr;
        getline(cin, tempStr);
        // cout << tempStr.length();
        cout << justifyPassword(tempStr) << endl;
    }
    return 0;
}

优化代码

c++ 复制代码
#include <bits/stdc++.h>
using namespace std;

bool ifValid(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isalnum(c) || c == '.'; });
}

bool ifOnlyLetter(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isalpha(c) || c == '.'; });
}

bool ifOnlyNum(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isdigit(c) || c == '.'; });
}

string justifyPassword(const string &password)
{
    if (password.length() < 6)
        return "Your password is tai duan le.";
    if (!ifValid(password))
        return "Your password is tai luan le.";
    if (ifOnlyLetter(password))
        return "Your password needs shu zi.";
    if (ifOnlyNum(password))
        return "Your password needs zi mu.";
    return "Your password is wan mei.";
}

int main()
{
    int N;
    cin >> N;
    cin.ignore();
    while (N--)
    {
        string tempStr;
        getline(cin, tempStr);
        cout << justifyPassword(tempStr) << endl;
    }
    return 0;
}
  • 不用复杂的正则表达式判断密码是否合法,而是运用了三个函数isalnum()判断是否为字母或数字,isalpha()判断是否为字母,isdigit()判断是否为数字,加上all_of,对整个字符串进行检查。
  • 使用cin.ignore()而不是getchar()来读取缓冲区的换行符
相关推荐
大数据追光猿1 小时前
Python应用算法之贪心算法理解和实践
大数据·开发语言·人工智能·python·深度学习·算法·贪心算法
Dream it possible!1 小时前
LeetCode 热题 100_在排序数组中查找元素的第一个和最后一个位置(65_34_中等_C++)(二分查找)(一次二分查找+挨个搜索;两次二分查找)
c++·算法·leetcode
夏末秋也凉1 小时前
力扣-回溯-46 全排列
数据结构·算法·leetcode
南宫生1 小时前
力扣每日一题【算法学习day.132】
java·学习·算法·leetcode
柠石榴1 小时前
【练习】【回溯No.1】力扣 77. 组合
c++·算法·leetcode·回溯
Leuanghing1 小时前
【Leetcode】11. 盛最多水的容器
python·算法·leetcode
qy发大财1 小时前
加油站(力扣134)
算法·leetcode·职场和发展
王老师青少年编程1 小时前
【GESP C++八级考试考点详细解读】
数据结构·c++·算法·gesp·csp·信奥赛
qy发大财1 小时前
柠檬水找零(力扣860)
算法·leetcode·职场和发展
瓦力的狗腿子1 小时前
Starlink卫星动力学系统仿真建模番外篇6-地球敏感器
算法·数学建模·simulink