洛谷 B3637 最长上升子序列 C语言 记忆化搜索->‘正序‘dp

题目:

https://www.luogu.com.cn/problem/B3637

最长上升子序列

题目描述

这是一个简单的动规板子题。

给出一个由 n(n\\le 5000) 个不超过 10\^6 的正整数组成的序列。请输出这个序列的**最长上升子序列**的长度。

最长上升子序列是指,从原序列中**按顺序**取出一些数字排在一起,这些数字是**逐渐增大**的。

输入格式

第一行,一个整数 n,表示序列长度。

第二行有 n 个整数,表示这个序列。

输出格式

一个整数表示答案。

样例 #1

样例输入 #1

```

6

1 2 4 1 3 4

```

样例输出 #1

```

4

```

提示

分别取出 1234 即可。

思路就是,求出第(1~n)为子序列结尾的最大长度,然后比较一下。用mem数组储存,我画了一个案例图,可以清楚地看出重复部分。

#include<iostream>
#include<algorithm> 
using namespace std;
int n;
int nums[5005];
int mem[5005];
int dfs(int k)
{
	if(mem[k])
	return mem[k];
	int sum = 1;
	for(int i = 1 ; i < k ; i++)
	{
		if(nums[i] < nums[k])
		sum = max(sum,dfs(i)+1);
	}
	mem[k] = sum;
	return sum;
}
int main(void)
{
	int ans = -1e10;
	cin >> n;
	for(int i = 1 ; i <= n ; i++)
	cin >> nums[i];
	
	for(int i = 1 ; i <= n ; i++)
	{
		ans = max(ans,dfs(i));
	}
	cout << ans;
	return 0;
 } 

动态规划:'正序'dp

#include<iostream>
#include<algorithm> 
using namespace std;
int n;
int nums[5005];
int f[5005];

int main(void)
{
	int ans;
	cin >> n;
	for(int i = 1 ; i <= n ; i++)
	cin >> nums[i];

	for(int i = 1 ; i <= n ; i++)
	{
		f[i] = 1;
		for(int j = 1 ; j < i ; j++)
		{
			if(nums[j] < nums[i])
			f[i] = max(f[i],f[j] + 1);
		}
	}
	sort(f+1,f+1+n);
	ans = f[n];
	cout << ans;
	return 0;
 } 
相关推荐
直裾2 分钟前
scala借阅图书保存记录(三)
开发语言·后端·scala
唐 城23 分钟前
curl 放弃对 Hyper Rust HTTP 后端的支持
开发语言·http·rust
嵌入式科普1 小时前
嵌入式科普(24)从SPI和CAN通信重新理解“全双工”
c语言·stm32·can·spi·全双工·ra6m5
火星机器人life1 小时前
基于ceres优化的3d激光雷达开源算法
算法·3d
虽千万人 吾往矣1 小时前
golang LeetCode 热题 100(动态规划)-更新中
算法·leetcode·动态规划
arnold662 小时前
华为OD E卷(100分)34-转盘寿司
算法·华为od
ZZTC2 小时前
Floyd算法及其扩展应用
算法
码银2 小时前
【python】银行客户流失预测预处理部分,独热编码·标签编码·数据离散化处理·数据筛选·数据分割
开发语言·python
从善若水2 小时前
【2024】Merry Christmas!一起用Rust绘制一颗圣诞树吧
开发语言·后端·rust
lqqjuly2 小时前
特殊的“Undefined Reference xxx“编译错误
c语言·c++