docker简单私有仓库的创建

1:下载Registry镜像

导入镜像到本地中

root@localhost \~# docker load -i registry.tag.gz

进行检查

2:开启Registry

registry开启的端口号为5000

root@localhost \~# docker run -d -p 5000:5000 --restart=always registry

root@localhost \~# docker ps

3:上传镜像到仓库中

root@localhost \~# docker tag nginx:v3 172.25.254.200:5000/nginx.v3

root@localhost \~# docker push 172.25.254.200:5000/nginx.v3

docker在上传的过程中默认使用https,但是我们并没有建立https认证需要的认证文件所以会报错

配置非加密端口为本地虚拟机的IP地址。

root@localhost \~# vim /etc/docker/daemon.json
{

"insecure-registries":"http://172.25.254.200:5000"

}

重启docker

root@localhost \~# systemctl start docker

4:上传镜像

root@localhost \~# docker push 172.25.254.200:5000/nginx.v3

root@localhost \~# docker inspect happy_colden

数据挂载目录的位置

进入到数据挂载目录的位置,里面存在上传镜像nginx.v3

快捷方式访问

root@localhost \~# curl 172.25.254.200:5000/v2/_catalog

{"repositories":"nginx.v3"}

总结

将本地的镜像推送到私有仓库中

root@localhost \~# docker tag busybox:latest 172.25.254.200:5000/busybox:latest

打上标签,上传镜像

root@localhost \~# docker push 172.25.254.200:5000/busybox:latest

相关推荐
小白的码BUG之路8 小时前
Docker -- 构建ruoyi-system镜像
运维·docker·容器
小白的码BUG之路8 小时前
Docker -- 构建redis镜像
运维·docker·容器
吴声子夜歌9 小时前
Nginx应用与运维——Nginx Web服务应用实战(HTTPS安全服务器的搭建)
运维·前端·nginx
江湖有缘9 小时前
Docker实战 | 使用Docker部署EspoCRM开源客户关系管理平台
docker·容器·开源
wdfk_prog9 小时前
Wi-Fi Direct 源码分析(09):从 P2P_CONNECT 到 GO Negotiation 完成
运维·服务器·ubuntu·golang·asp.net·p2p·wifi-direct
忆挽篱笙歌9 小时前
linux开发工具
linux·运维·ubuntu
吴声子夜歌9 小时前
Nginx应用与运维——Nginx Web服务应用实战(伪流媒体服务器的搭建)
运维·前端·nginx
Lsetea9 小时前
OpenSSL verify报certificate signature failure:error 7与证书签名排查
运维·https·ssl证书·openssl·证书链
吴声子夜歌9 小时前
Nginx应用与运维——Nginx Web服务应用实战(HTTP增强协议服务器的搭建)
运维·前端·nginx
小白的码BUG之路9 小时前
Docker -- 构建ruoyi-auth镜像
运维·docker·容器