docker启动报错code=exited, status=1/FAILURE——问题排查

问题

在某台centos7机器上,启动docker服务

复制代码
sudo systemctl start docker

报下列错误:

复制代码
● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Fri 2025-02-07 16:17:41 CST; 3s ago
     Docs: https://docs.docker.com 
  Process: 60262 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
 Main PID: 60262 (code=exited, status=1/FAILURE)

该错误什么信息都没有透露,但是我们可以通过查看docker日志,来进一步分析原因。

日志

查看 Docker 守护进程的日志,以获取更多错误信息

复制代码
sudo journalctl -u docker.service

得到下列日志信息:

复制代码
Feb 07 16:10:17 localhost.localdomain dockerd[54216]: time="2025-02-07T16:10:17.194747005+08:00" level=info msg="Firewalld: docker zone already exists, return
Feb 07 16:10:17 localhost.localdomain dockerd[54216]: time="2025-02-07T16:10:17.691552194+08:00" level=warning msg="could not create bridge network for id 50d
Feb 07 16:10:17 localhost.localdomain dockerd[54216]: time="2025-02-07T16:10:17.771015154+08:00" level=info msg="stopping event stream following graceful shut
Feb 07 16:10:17 localhost.localdomain dockerd[54216]: failed to start daemon: Error initializing network controller: Error creating default "bridge" network: 
Feb 07 16:10:17 localhost.localdomain systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE
Feb 07 16:10:17 localhost.localdomain systemd[1]: Failed to start Docker Application Container Engine.

基本能够断定Linux的防火墙和docker的网络冲突导致的

解决

首先查看防火墙配置,命令如下:

复制代码
firewall-cmd --list-all-zones

会看到docker0的配置,此时需要将docker0的配置删除

如果docker0在public,删除命令是:

复制代码
firewall-cmd --zone=public --remove-interface=docker0

如果docker0在trusted,删除命令是:

复制代码
firewall-cmd --zone=trusted --remove-interface=docker0

删除完之后,重启docker

复制代码
systemctl restart docker
相关推荐
虎头金猫3 天前
4K 视频总卡在公网带宽?用 N1 + OpenList 把网盘播放链路重新理顺
运维·服务器·网络·python·容器·beautifulsoup·pandas
分布式存储与RustFS3 天前
MinIO 官方 Docker 镜像被移除:依赖它的项目该怎么办
docker·云原生·devops·对象存储·minio·分布式存储
玉&心3 天前
通过Arthas在线诊断K8S中的内存及JVM等使用情况
docker·k8s·arthas
xing-xing3 天前
Docker容器中Nginx站点根目录网页配置访问
nginx·docker
赵文宇(温玉)3 天前
CoreDNS的hosts插件的缺行配置导致k8s集群异常
容器·kubernetes·rancher
guo_wen_qiang3 天前
上传本地镜像到harbor中
docker·容器·持续部署
羑悻的小杀马特3 天前
Dockerfile 全景指南:从入门编写dockerfile到生产环境镜像优化实战,一步步带你从啃透制作指令到镜像制作落地!
docker·dockerfile·镜像制作
BianHuanShiZhe3 天前
docker常见命令
docker
正经教主3 天前
【FDE系列】阶段2:Day 43:Docker Compose — 多容器一键编排
人工智能·docker·fde
忆~遂愿3 天前
本地片库怎么在外面打开?Plex + cpolar 搭一套可远程访问的私人影音库
docker·容器